Upgraded to 2.4 today and...all instances are gone!

OS Name/Version: Debian GNU/Linux 11 (bullseye)

Product Name/Version:

Problem Description:

As the topic says, I have upgraded to but now none of my instances are listed! Thankfully the instance data is still there, and I’ve got a backup. But I really don’t want to recreate said instances manually.

Steps to reproduce:

  • Upgrade to
  • Reboot - done automatically
  • Loss

Actions taken to resolve so far:

Have tried to reboot, just in case a process was stuck, this has not helped. Have also left it for a good number of minutes (roughly 20) to see if it would magically resolve itself.

I assume there is going to be a very simple Install Manager script I can run to resolve this? If not, just let me know what you need and I will do what I can to provide.

Known issue, don’t worry they’re not gone - a fix will be available very shortly.

I have absolutely the same problem. The upgrade started, then the AMP page on the server became unavailable. Refreshed browser and AMP came back, but all instances are missing.

Tried doing an apt-get upgrade to update AMP (as it appears the web based update failed) and I get the error below.

Screenshot 2022-09-09 235437

Just hold fire for a moment, rebuilds and resyncs are in progress so it’s a little up in the air. It’ll all sort itself out in a few minutes now.

Hi Mike,

I am both concerned and relieved by this :wink:

I will patiently wait for said fix to make it’s way to the world of the living :slight_smile:

Run ampinstmgr --nocache upgradeall and you should be good now. The repos are also synced so you can update ampinstmgr itself as normal.

Windows users, you may need to do the full ‘refresh’ : Something not working on Windows? Try the following: - Docs - CubeCoders Support