Update Failure with Palworld - Palworld Instance will not launch or update

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.4 (Mainline)
Virtualization Docker
Application Palworld
Module GenericModule
Running in Container Yes
Current State Stopped

Problem Description


I am making a second post as the AMP has since been updated with some testing but the Palworld instance and I feel the first post was a bit muddled. Basically from restarting the server, to logging out and back in, to trying update and start separately, will not update or launch the instance. I can’t think of any other basic troubleshooting steps and I’m unsure if there’s a manual way to force the update.

Reproduction Steps

  • See both the Start and Update option on the Instance under Status. Click on the Start button. This brings up the notifications of
  • the update step 1/2 SteamCMD Download. But once this proceeds to the installation it processes for a minute or two then returns to the Start and Update buttons being present with no change.
  • Start and Update buttons both result in the same result. Logging out and back in and Restarting the whole server have not resolved it.

I am not very familiar with servers, this is my first time using them, so if you could dumb down any responses or steps I’d greatly appreciate it.

I have the same problem on a windows server. Start and update button result both in only updating but not starting the server after updating the callisto version.

Search the forum - update your instance

I’m sorry but the entire post is about how I cannot update the instance. Can I please get some guidance on how to do this instead of vaguely directing me to other posts? I am not familiar with any of these things and am requesting that bit more assistance with this because of this. It would save me a ton of time if you could provide a link to a step by step guide or provide steps on how to do this as I am not familiar with these processes like you are.

Screenshot pertaining to the next messages, this is the result.

1 Like

Click Return to Instances.

Click Stop on the Palworld instance.

Click Update on the Palworld instance.

Check console for any errors.

If fine, you are set.

Thanks, these are the screenshots of what I’m doing and the results in order. I stopped the instance first. Then started it, it tried to update and I was left with this screen.

Pressing Start or Update results in this screen.

That loops back to the first screenshot again. The console show’s nothing that looks like an error but it does end with Quit and it never seems to update or launch the instance. So it just seems to loop. I will try edit the second screenshot onto the previous message as I can only attach one at a time.

I tried it many times and now it is stuck at updating Palworld and steamCMD is still half-loaded


Did you click “I have taken a backup”?

Yes, I have clicked “I have taken a backup”
so from the server, I would click return to instances, stop instance, update, andI have taken a backup. Then it will just stuck at downloading palwolrd or redownloading it; while steamCMD is always halfway during this whole thing.
Screenshot 2024-04-06 201758

Also follow this. Palworld template update

Just note that you will need to pull the latest template update by going to Configuration > instance deployment and press fetch latest

Second sentence not required. The instance update will pull the updated templates.