Unable to update to 2.4.3

OS Name/Version: Windows 10 (64 bit)

Product Name/Version:2.4.2

Problem Description: Unable to update to

Ive tried the update now button about 10 times. Ive tried the update now button through the support tab. I tried re-downloading the installer and using that to repair the install. I have rebooted the PC hosting it. Ive tried to use the commands from :

But the commands don’t seem to execute in the console.

I’m very confused on why i cant update, have i missed something obvious? Any help or links would be great.

Thanks :slight_smile:

Show me a screenshot of you running the command?

1 Like

1 Like

Can you try installing .Net Framework 4.7.1 please?

1 Like


Looks like it is already installed

1 Like

Righto, I shall have to look into this.

1 Like

Thanks Mike, really appreciate it :slight_smile:

Chiming in to confirm I have the same issue on my test machine.

1 Like

I think I know what’s up, you might find that simply deleting the app.config file alongside ampinstmgr.exe solves it if I’m right.

1 Like

That did work. And here’s some extra words to meet the minimum.


Fantastic @Mike that was it, thanks so much for looking into this i really appreciate it! :smiley: , thanks so much!
@IceOfWraith Thanks to you as well for confirming my issue and testing the solution really happy everything is working now :smiley:

I’m just updating the installer with the tweaked file, so anyone else can just uninstall/reinstall and it’ll work.

1 Like

This worked for me also.

Thanks everyone!

I dont have the app.config file and its still not installing

Same here. Only .config files I have are ampinstmgr.exe.config and InstanceManager.exe.config, but removing those only prevents the program from opening. Either way, still can’t update to 2.4.3. Just thought I’d post and see what else I can to to get the update working. Thanks.

There’s been a new installer shipped. Remove the old one via add remove programs and fetch a fresh copy.

Same issue on Windows Server. Uninstalling it from Add or Remove does not help. Update button doesn’t update it. And installing the .exe from CubeCoders Limited results in the program still telling me it needs to be updated.

I do have the latest .net framework

To clarify - you uninstalled the AMP Instance Manager application via add/remove programs - installed a fresh copy, and have then run ampinstmgr upgradeall ?

Running ampinstmgr upgradeall in the windows CMD fixed it!

This worked perfectly for me without having to modify/ remove any other files. Thanks :slight_smile: