Unable to Manage New Remote Instances after Upgrade to AMP 2.4.X.X

OS Name/Version: Ubuntu 20.04.3 LTS

Product Name/Version: AMP

Problem Description: I’m unable to manage new instances created after the upgrade to AMP from 2.3.X.X. I created a new instance (for Terraria) via the GUI, which was successful and then I had to update my AMP/ADS instance to the latest to try to manage it, which I went through and was successful, but I’m unable to manage this new instance. Every time I try to manage the new instance, I run into similar issues as this thread where it hangs for a minute and then returns an Unknown Error, with the logs pointing to the same SocketException : Connection Timed Out error.

One thing to note, I can manage existing instances that were created prior to the update to 2.4.X.X, but any instances I create after 2.4.X.X I encounter this same issue.

I ran through a lot of the commands mentioned in the above linked thread, and one thing I noticed when running ampinstmgr status is that for the instance that works and I can manage, the IP is showing, whereas any new instance created on 2.4.X.X is showing and I can’t connect to it. I don’t know if that’s just coincidental and it’s a port issue instead of that IP, but wanted to call attention to it just in case.

[Info] AMP Instance Manager v2.3.0.6 built 02/12/2021 15:38
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance Name      │ Friendly Name    │ Module     │ IP              │ Port  │ Up
ADS01              │ ADS01            │ ADS        │         │ 8080  │ ✓
Minecraft01        │ Minecraft Mi...  │ Minecraft  │       │ 8081  │ ✓
Terraria01         │ Terraria Te...   │ Generic    │         │ 8082  │ ✓

Steps to reproduce:

  • Created new Terraria instance
  • AMP prompted me to upgrade AMP install to latest to access instance created on 2.4.X.X
  • Upgraded AMP to
  • Start new instance and try to click manage
  • Times out after 10 connection attempts, logs show entries for IOException) : Unable to read data from the transport connection and SocketException : Connection timed out
  • Upgraded existing Minecraft instance that was created with AMP 2.3.X.X
  • Click manage on Minecraft instance and it connects to the instance successfully.

Actions taken to resolve so far:

  1. Tried to delete and recreate instance, same issue
  2. Restarted AMP, same issue.
  3. Ran ampinstmgr --UpgradeAll to make sure all instances were the same version, issue persists
  4. Ran the AMP command to update firewall:
sudo ampinstmgr updatefirewall
[Info] AMP Instance Manager v2.3.0.6 built 02/12/2021 15:38
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] Using UFW firewall.
[Info] No new firewall rules to add
[Info] No existing firewall rules to remove
  1. Tried manually adding TCP 8082 any/any to UFW, same issue

Any thoughts on what’s going wrong, what else I can check/try, etc? All help is greatly appreciated.

Update your copy of ampinstmgr, your logs show it’s out of date.

Ah, I mistakenly thought by running ampinstmgr --UpgradeAll it would upgrade the ampinstmgr as well, but overlooked that. Doing that now and I’ll report back!

@Mike Updated ampinstmgr to latest as shown below, issue is still present. I also restarted the entire server that AMP is hosted on to see if a full restart of everything would help, but no luck, still same behavior where existing instances work, and new instances post don’t work.

[Info] AMP Instance Manager v2.4.0.8 built 10/10/2022 18:49
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

In the AMPConfig.conf for your instances, is the AuthServerURL set to http://localhost:8080/ ?

@Mike nope, it is set to a different local internal IP, Guessing I should set that to localhost?

Update: I went ahead and made that change, restarted the instance, and I can now manage it! Thanks for the help pointing me in the right direction.

It’s weird that it was set to that 192.168 IP though, since that IP doesn’t show up anywhere else in AMP at all. All of my “Default IP Binding” settings in AMP under the Configuration > Networking page are all set to, so again not really sure how it got that IP for the AuthServerURL setting.

You want to check the setting under New Instance Defaults too. :slight_smile: