Cant manage Minecraft instance

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Ubuntu Server 20.04 running in VM on Truenas

Product Name/Version: AMP v2.3.4.4 built 26/07/2022 20:08 (Release Build)

Problem Description:

Manually set a fixed IP to AMP, can no longer manage instances.

Console: Failure to make API call to JallysMineyServer ( - retried 10 times : The operation was canceled.
[0] (TaskCanceledException) : The operation was canceled.
at ADSModule.WebMethods.MakeInstanceRequest (m.Http.IHttpRequest request, String REQ_RAWJSON, String requesturi) at ADSModule.WebMethods.Servers (m.Http.IHttpRequest request, String id, String REQ_RAWJSON)
[1] (IOException) : Unable to read data from the transport connection: Operation aborted.
at Net.Sockets.Socket+AwaitableSocketAsyncEventArgs.ThrowException (Net.Sockets.SocketError error) at Net.Sockets.Socket+AwaitableSocketAsyncEventArgs.GetResult (Int16 token) at Net.Http.HttpConnection.FillAsync () at Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync (Boolean foldedHeadersAllowed)
[2] (SocketException) : Operation aborted

Steps to reproduce:

  • Step 1: Change Fixed IP
  • Step 2: Login in via new IP
  • Step 3: Click Manage on instance

Actions taken to resolve so far: Deleting and creating new instance, [web] Can't manage instance after host IP address change Trying these commands without standalone but it can never find the ADS instance.

Do you have multiple IP addresses on your system? Unless you do then you shouldn’t put AMP on a fixed IP. ADS01 should be, everything else must be

Multiple static IPs for the various VMs running on the system, will take off the static IP flag on AMP if that is whats causing issue.

By itself that isn’t the problem - but it does warn you for good reason that rebinding ADS01 will cause problems, lots of other steps are required afterwards to get it all behaving.

Weirdly its happened again even without the IP being fixed and the server working last night. Any suggestions on a fix?

Are you using Docker for the instances?

No not using docker afaik

What’s the output of ampinstmgr status ?


But the instance says running on AMP

You need to be logged in as the amp user to run most ampinstmgr commands. Typically sudo su -l amp to switch.

Oh yeah duh,


What’s the output of ip addr ? (Censor your public IP if shown, but leave everything else intact)

And of sudo ampinstmgr updatefirewall please (not as the amp user this time)

Ah, if you run ufw status does it say inactive ?



Cool, either:

A) Allow SSH through UFW then enable UFW, or
B) Uninstall UFW and wait 5 minutes for AMP to sync via iptables.

Removed UFW and waited 5 mins, still no luck, restarted VM and tried again still recieving this error

Run sudo ampinstmgr updatefirewall again and show me the output.