Startup Issue with Modded Minecraft - ./Minecraft/minecraft_server.jar is missing

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.4 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Failed

Problem Description


I have a pre-existing server that I confirmed works on my PC. I uploaded all of the server files, added the unix args in Java and Memory, and configured it to use Forge and the correct forge version with the jar as Auto Select. I even tried clicking Download/Update. Upon clicking start I get the error message “The update manager reported a successful update, but ./Minecraft/minecraft_server.jar is missing.”.

Reproduction Steps

  • Created All The Mods 9 server on PC
  • Uploaded server files to AMP
  • Copy and pasted unix args to additional Java options
  • Set server type to Forge and selected the correct Forge version
  • Clicked Start Button

Try hitting Download/Update before starting the server, and make sure that the server Jar is set to Autoselect

“I even tried clicking Download/Update.”

“with the jar as Auto Select.”

As stated, I have tried both and have done such again before typing this.
Thank you for your response though. :+1:

Ah, my bad, I managed to miss that somehow.
Maybe remove the Java args, then give the instance a stop/start, see if that kicks it over.
Then if that works add the args back a few at a time.
If you use -XX:-DontCompileHugeMethods at all, there’s a bug with how AMP reads in the arg, so you’ll need to remove it till it’s fixed.

Removing the args and stop/starting the instance doesn’t seem to do it.
The only way I can get the server to start is if I take a copy of the forge jar, rename it to minecraft_server.jar, and place it in the main directory.
I then of course get errors and the server crashes.

I’m assuming this has to do with AMP not being able to find the forge jar. Would this have something to do with the startserver.bat that comes with the modpack’s server files? I wonder if there’s a way to transfer its contents to AMP…

If it’s Forge 1.17-1.20.1 there is no real Jar, which causes problems for everyone (amp has a built-in workaround).
The startserver.bat wouldn’t have anything important that AMP doesn’t already do.
Just curious, what version of Forge are you running and what Java runtime version are you using?

The Forge version is 47.2.20 and I have TEMURIN 17 selected.

Weird, sounds like you have everything all lined up correctly.
Sanity check time

  • Did you mess with the files as the root user or with sudo at all? If so run ampinstmgr fixperms as root
  • You could try and delete the Forge installer and the libraries directory, then try and hit Download/Update again
  • I didn’t mess with that, I don’t even know where it is lol
  • No luck.

No idea what’s going on then tbh, you might be best off creating a new instance, setting up Forge, running it to see if it works, then finally, install the modpack.

I have tried what you said with 2 more instances and thankfully no longer get the server jar errors. However, I now keep getting the same crash errors. Something about it not being able to parse data files. This is the same error that I had a while ago and I fixed it on my PC by correcting the ip and port settings in the server properties file. I’ve made sure in these 2 instances the settings are all correct in both the files and the actual configuration settings of the instances.

Here’s a link to the log file if you’d like to have a look, I have no idea how to diagnose it: Forge 1.20.1 Server Log [#xpRxosw] -

All of this is driving me mad, is there somewhere where I could receive further help if you are at a loss? I appreciate all of your assistance thus far, thank you.

Those sorts are errors are pretty common with modern modded from what I’ve seen.
Is it fully crashing (as in the server suddenly stops during startup), or is it just a ridiculous amount of console garbage? If it’s the latter and the server starts fine, it’s safe to ignore.
Though option 3: if the server just stops loading mods partway through starting. This can usually be solved by re-uploading the configs.

Once it says all the failed to parse stuff it just restarts the server again, it never actually starts fully.
I re-uploaded the configs to no avail.

Odd, does it just cut off at that same point?
Could be a bit of a hail mary, but you could try and re-upload the mods as well if you haven’t already.
Gotta love Forge, cause I’ve had ATM9 working fine in AMP a few different times.
And just a general sanity check, maybe try removing any added Java args and make sure that there’s enough ram allocated to the ATM9 server (maybe 5-6GB at a minimum, the pack should run a bit more decent at 8GB)

Yeah, it cuts off right after those errors.
Re-uploaded the mods with no luck.
Removing the java args also doesn’t make a difference.
The server has 8GB and I allocated 7.5 to the instance.
I even tried creating a new instance following these instructions I found deep in a git specifically for this modpack and I get the same errors.

Yeah, I’m kinda at a loss here. Looks like you have everything all set up right, it runs, but it just doesn’t wanna play.
Just as a final double-check, would you mind managing the instance, go to Support and Updates, then hit Copy support data to clipboard and share that here

OS Linux
Platform Debian GNU/Linux 12
System Type x86_64
CPU Model AMD EPYC 7543P 32-Core Processor
CPU Layout 1S/2C/2T
Installed RAM 7959
Virtualization Docker
Module MinecraftModule
Module Application Minecraft
Loaded Plugins FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
Application Name AMP
Application Version
Codename Callisto
Tools Version
Release Stream Mainline
Build Spec Release
Build Date 17/04/2024 22:09
InstanceID 86596b58-f275-45b5-a3ba-817eabe54247
Last Executable /usr/lib/jvm/temurin-21-jdk-amd64/bin/java
Last Arguments -Xmx7680M -Xms256M @libraries/net/minecraftforge/forge/1.20.1-47.2.20/unix_args.txt
Last Process ID 921

I wonder… Try swapping it over to Java 17 under Java and Memory, I completely missed that bit in your log.
If it says Java 17, swap it to something else, wait a couple secs, then swap it back to Java 17 (the setting rarely gets hung up)

Wow, I did not see that it was trying to use 21, It showed 17 selected.
Regardless, I got it to swap but the problem is still there.

I’m out of Ideas at this point, gotta love modded MC and it’s interesting behavior.
If you end up getting it working somehow I’ll add your solution to the “if Forge breaks, try these” knowledgebase post

(or who knows, maybe someone who’s had this exact issue will turn up with some insight)