License/instance and network issues

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Windows 10 Pro

Product Name/Version:

Problem Description:

  1. Issue with restarting Amp services in Windows. If I restart services, it prevents all access to the internet on the machine involved. No traffic passes period. No logs show an issue but if trying to browse to a random site, it will time out.
  2. Licensing issues. It appeared to have accepted the key. I’ve tried this with and without the dashes… latest attempt left me in a state where the amp panel says system lost licensing… reactivate. I’ve also done this a dozen times now… to no avail.
  3. Instance issues. When I AM able to get past the issue, the instance won’t start giving the wonderful error 32, no Licence.

Steps to reproduce:

  • Step 1 - start amp after fresh install and fresh reboot.
  • Step 2 - Key in license

Actions taken to resolve so far:

Uninstall Amp
Reboot Computer
Reinstall Amp
Relicense Amp.

Thanks for any pointers!

Do you have VPN software installed on the system? This includes tunneling software like Hamachi.

No VPN is running. Just standard networking via onboard port. I’ve tried other panels and none seem to have this issue.

Try changing the startup mode of AMPs service to Delayed Start.

AMP won’t have anything to do with other applications not being able to access the network though. It doesn’t touch the systems network configuration beyond adding its own firewall rules (which you can see under the normal Firewall control panel)

But a misbehaving network will cause AMP to misbehave as it tries to query things like the primary MAC address which ties into its licencing system.

I did change the service to delayed start but it does not seem to have made a difference.

When I reopened the AMP panel, it told me the license was lost and I had to rekey it. Did so and did the reactivate local instances as the panel instructed. Went to start the instance and manage it so i could complete a minecraft setup and it failed:



Instance Minecraft101 has stopped

ADS logged stopped instance Minecraft101 - exit code 32 (NO_LICENCE)

Reactivating instance Minecraft101…


Waiting for AMP instance to start…

AMP instance Minecraft101 is now running.

Managed remote instance Minecraft101 at

Authentication token for admin requested by ManageInstance on behalf of admin

Slow method invocation: ManageInstance took 3518ms to complete.

Slow response: ADSModule.ManageInstance took 3518ms to complete.


LIM - Failure to make API call to Minecraft101: An error occurred while sending the request.

Slow method invocation: Servers took 2055ms to complete.

Slow response: ADSModule.Servers took 2056ms to complete.

I do have a question about the license… do you need to key in with or without dashes? I’ve tried both to no avail. This same set of messages keeps coming up when trying to start the instance.

I have now also deleted the one instance I have and created a new one. It issues the exact same problems as noted above. The instance stops as soon as it starts with the Error 32 No Licence.

It’s with the dashes, 36 characters total - but if the key is wrong for any reason it says so very clearly.

Each instance has its own AMPConfig.conf file - if you find that there’s a setting called LogLevel. Set its value to 0 and you’ll get more information about what’s going on.

Reactivate the instance on the command line, then start it up again. Then check its most recent log and see what it says.

I did set log level but the console in the panel reveals no further information other than the error 32, No License.

I did the reactivate all, it pulled the license type as MCMYADMIN PRO but I am guessing that is ok. It also stated that it was reactivating instances. This did not seem to make a difference.

I also restarted AMP and performed a reboot as well.

Aah, for McMyAdmin licences you have to enable Deprecated applications in ADS and make sure to specifically pick the “McMyAdmin” instance type. That’s the only one that legacy MCMA2 keys can use.

I am extremely curious now. When I purchased the license just a day or two ago, that was the license that I received… not a current one… is that also normal?

That implies that you bought a licence from and not - if it was recent then send a one-line email to and I can swap your key out for an actual AMP one.

I will send that email now.
Email sent.
I will say a VERY long time ago i did have McMyAdmin but I did purchase my current license directly through cubecoders site.

Wait - that sounds more like then that you just gave AMP the wrong key incorrectly?

Edit: You don’t have an AMP key from the email address you sent the email from. So you’ve got another account somewhere.

Ok, here goes.

I went back to manage licenses, it now shows AMP Pro not McMyAdmin.
I requested the license again, went to AMP Panel after restarting it, made sure new instance key was rekeyed.
It shows an activation now on the AMP License manage site.
New Key was sent. I did the reactivation on command line.
Created new instance, still says error 32, no license.

All of this done from the same email address I sent the email from btw. Manage license portal once had mcmyadmin. Now it shows Amp Pro

Run ampinstmgr reactivateall AMPLICENCEKEYGOESHERE and reboot.

Edit: Also re-enter the key under Configuration → New Instance Defaults in ADS.

Did as requested and it still does this exact same issue. Website Lic Manager shows license activated… even deleted the datastore I had created and placed new instance on default datastore… it still would crash saying the Exit Code 32.

You need to check the logs for the instance rather than ADS to see what’s up.

Here is what is found in the instance log. I did as the log requested to manually reactivate and it still has the same information in the logs after.

[01:48:10] [Program Info] : Starting AMP version (Decadeus), built 07/09/2023 18:02
[01:48:10] [Program Info] : Stream: Mainline / Release - built by CUBECODERS/buildbot on CCL-DEV
[01:48:10] [Core Warning] : Current time zone is set to Central Standard Time - It is recommended you switch to UTC+0 to avoid time-zone related issues
[01:48:10] [Program Info] : OS: Windows / x86_64
[01:48:10] [Program Info] : CPU: Intel(R) Core™ i7-5820K CPU @ 3.30GHz (6C/12T)
[01:48:10] [Program Info] : RAM: 32680MB
[01:48:10] [Program Info] : AMP Instance ID: XXXXX
[01:48:11] [Loader Info] : Loaded MinecraftModule version by CubeCoders Limited
[01:48:11] [Core Info] : Metrics publishing is enabled at udp://localhost:12820.
[01:48:11] [Loader Info] : Loaded FileManagerPlugin by CubeCoders Limited
[01:48:11] [Loader Info] : Loaded EmailSenderPlugin by CubeCoders Limited
[01:48:11] [Loader Info] : Loaded WebRequestPlugin by CubeCoders Limited
[01:48:11] [Loader Info] : Loaded LocalFileBackupPlugin by CubeCoders Limited
[01:48:11] [Loader Info] : Loaded CommonCorePlugin by CubeCoders Limited
[01:48:11] [Core Info] : Licence Present: AMP Professional Edition
[01:48:12] [FileManager Notice] : Using keypair with fingerprint XXXXX
[01:48:12] [FileManager Info] : SFTP Server started on
[01:48:12] [Core Error] : No valid AMP licence was found. Please open a command prompt and run ampinstmgr reactivate instance1 to reactivate this instance.

Apparently it is not reactivating the instance once the license is ready. I’ve installed the license where new instance creation goes, rebuilt(delete/recreate) the instance, manually apply the license, and no change in behavior

Go to Configuration → New Instance Defaults and re-enter the licence key - then make a new instance. Does that instance run?

It does not. It starts and stops with the same issues. I’ve deleted and created instances to test in between applying livenses.

Can you look at that instances AMPConfig.conf and check what the value of AppModule is?

If it’s “McMyAdminModule” then the problem is that you’re using the wrong application type.