Game Servers not starting after last update

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Windows 10

Product Name/Version: AMP Instance Manager v2.3.2.12

Problem Description:

Not able to start Game servers after last update - error relating to licence.

Management Instance seems OK, nothing to note in the logs and is able to start.

Steps to reproduce:

  • Update instances to latest version
  • server not longer work

Actions taken to resolve so far:

Review logs for game instance:
In server logs I see this:

[10:30:35] [GSMyAdmin Warning]    : Current time zone is set to AUS Eastern Standard Time - Servers should ideally be UTC to avoid time-zone related issues
[10:30:35] [GSMyAdmin Info]       : OS: Windows / x86_64
[10:30:35] [GSMyAdmin Info]       : CPU: Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz (6C/6T)
[10:30:35] [GSMyAdmin Info]       : AMP Instance ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[10:30:36] [GSMyAdmin Info]       : Loaded MinecraftModule version by CubeCoders Limited
[10:30:36] [Core Info]            : Metrics publishing is enabled at udp://localhost:12820.
[10:30:36] [GSMyAdmin Info]       : Loaded FileManagerPlugin version by CubeCoders Limited
[10:30:36] [GSMyAdmin Info]       : Loaded EmailSenderPlugin version by CubeCoders Limited
[10:30:36] [GSMyAdmin Info]       : Loaded WebRequestPlugin version by CubeCoders Limited
[10:30:36] [GSMyAdmin Info]       : Loaded LocalFileBackupPlugin version by CubeCoders Limited
[10:30:36] [GSMyAdmin Info]       : Loaded CommonCorePlugin version by CubeCoders Limited
[10:30:36] [GSMyAdmin Notice]     : Using keypair with fingerprint xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[10:30:36] [FileManager Info]     : SFTP Server started on
[10:30:36] [GSMyAdmin Error]      : No valid AMP licence was found. Please run `ampinstmgr reactivate MineCraft_Java` to reactivate this instance.

I run the command specified - I get this:

[Warning] Instances may not be created or modified using this tool while ADS is running. Either make the changes via ADS itself or stop ADS before making changes.
[Warning] You can do this by running 'ampinstmgr stop AMPMgtInstance'

I run this command to stop service and then run other command again.

Get prompted for Key - enter key and then get this:

[Info] Checking licence key...
[Info] Licence Type:  AMP Professional
[Info] Current Usage: 0
[Info] Reactivating instance MineCraft_Java...
[Error] IM was unable to execute the requested command.
[Error] MissingMethodException
[Error] [0] (MissingMethodException) : Method not found: 'System.Threading.Tasks.Task`1<Int32> ModuleShared.Utilities.RunUtilityAsync(System.String, System.String, System.String, System.String, Boolean, System.Collections.Generic.IDictionary`2<System.String,System.String>)'.
[Error]    at InstanceManagerPlugin.LocalInstanceManager.<ConfigureAMP>()
   at InstanceManagerPlugin.LocalInstanceManager.ConfigureAMP(AMPInstanceBase Spec, Dictionary`2 Args, RunningTask Task)
   at InstanceManagerPlugin.LocalInstanceManager.<ReconfigureInstance>()
   at InstanceManagerCLI.Core.<ReactivateInstance>()
   at InstanceManagerCLI.Core.ExecuteCommand(List`1 Params, Dictionary`2 Args)

See this thread: Something not working on Windows? Try the following:


Tried the steps in the link provided - still get same issue.

Anything else I can try?

Are you still getting the exact same messages? If so (specifically you’re getting MissingMethodException) then you didn’t follow the steps correctly.