Failed to login to remote instance

OS Name/Version: WIndows 10

Product Name/Version: AMP 2.4.0.10

After upgrading to 2.4.0.10 I can no longer log in to manage my Mincraft instance. I can log in to the top level of AMP, but clicking manage on my Minecraft instance gives me the error “Failed to login to remote instance”.

I’ve tried a variety of “ampinstmgr repairauth standalone http://localhost:8081” commands (it seems to occassionally change the port I’m using so I’m not always running that against 8081.

“ampinstmgr status” currently returns:

[Info] AMP Instance Manager v2.4.0.10 built 27/10/2022 18:16
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance Name │ Friendly Name │ Module │ IP │ Port │ Up
───────────────────┼──────────────────┼────────────┼─────────────────┼───────┼───
←]8;;http://127.0.0.1:8082/AMPInstance1-Sp…←]8;; │ AMP Instance … │ ADS │ 0.0.0.0 │ 8082 │ V
←]8;;http://127.0.0.1:8081/Minecraft ←]8;; │ Minecraft │ Minecraft │ 127.0.0.1 │ 8081 │

I’ve done some re-installs and some reboots. Still the same error message.

Any ideas?

Check the AMPConfig.conf for that instance, what is the Auth server URL set to?

C:\AMPDatastore\Instances\Minecraft\AMPConfig.conf:
Login.AuthServerURL=http://127.0.0.1:8082/

Also the log says:

[20:21:40] [System Activity] : Authentication attempt for user admin from 127.0.0.1
[20:21:41] [System Activity] : Authentication failure for user admin from 127.0.0.1 - TokenRejected

i have the same error i did the upgrade and now i cant manage the instance anymore

I still can’t manage this by clicking on it. However I just randomly right-clicked and selected manage in new tab. It prompted me to login, and it let me log in!

Is it possible that when logging in at the top level the login token is expired so quickly it isn’t present when trying to manage instances?

1 Like

Same for me, I just updated and I can’t manage my AMP instances from my principal instance.
It says “Failed to login to remote instance”.
Indeed right click and manage in a new tab works, but it’s not as intuitive as previously …