Connect to AMP Valheim server

Platform Fedora Linux 36 (Server Edition)
System Type x86_64
Virtualization QEMU_KVM
Module ADSModule
Loaded Plugins FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
Application Name AMP
Application Version
Release Stream Release
Build Date 29/09/2022 16:10
InstanceID 15562714-0213-4bfc-9bce-bb083061ad3e
Last Executable /usr/bin/docker
Last Arguments ps --format {{.Names}}
Last Process ID 464546

Product Name/Version:
Valheim dedicated server.

Problem Description:

I have setup the valheim server, set a password, and turned it on. I have done the necessary port forwarding. I then do a port check and verify the port the server is on is open on (27900) I cannot connect to the server locally or from an outside network. What can I do to fix this?

I am also running a seven days to die server. This server I am able to connect to just fine locally and I have a friend that plays with me that can connect as well. However, both servers will say (valheim and 7dtd) “server not responding” if I hit the “Connect to Server” button in valheim that pulls up the steam server interface.

Steps to reproduce:

  • Install AMP on fedora 36 server edition
  • install 7dtd server and set it up
  • Install valheim instance, set password, and start it up
  • click “Connect to server” in amp interface
  • Dialog box for either will say “Server not responding”
  • 7dtd will connect internally and externally
  • Valheim will not connect either way.

Actions taken to resolve so far:

Tried changing all the default ip bindings to the local ip address of the machine. Either way I could not connect whether using default settings or the above settings.

Tried installing on a Ubuntu VM and got the same result.

A quick note that this is running on a TrueNAS Scale box inside a Fedora 36 VM that has a GPU (GTX 970) Passthrough.

possibly the same issue as Valheim server not accessible?

I believe this is a coincidence. I have been trying to connect to a server on this machine for about three weeks now. It says the crossplay update came out on the 27 of September. I have been having this issue long before that update.