Conan Exiles server stuck at preparing to start

OS Name/Version: Ububtu 20.04

Product Name/Version: AMP

Problem Description:

I have installed a fresh instance of Conan Exiles. When I click start for the first time, the page just sits at “Application State: Preparing to start” and then nothing happens. Logs and console are empty.

Steps to reproduce:

  • Step 1 - Install Conan Exiles instance.
  • Step 2 - Try to start it.

Actions taken to resolve so far:

Removed instance and added it again, same problem.

Did you hit update so it’d download the Conan server?

Doesn’t it do an update at first start? It has for every other type of server I have installed. I will try it.

For apps that have weird requirements it can’t always do that right now.

Same thing. It did the update (I can see that in the log) and then just sticks at preparing to start, and there are no further entries in the log, nothing new was added to the log after the update.

Here is the log after the update finishes.

After clicking start, it switches to preparing to start and nothing else happens. As you can see, nothing further is added to the log, as if nothing actually happens after clicking start.

Just looking at the requirements for Conan, using AMPs docker mode is highly recommended for it because it has a stack of extra requirements that aren’t found in a standard Ubuntu install. It relies on Wine, xvfb and a couple of other bits.

OK so best practice would be to delete the current instance, and set up a new one under docker?

Unfortunately, I didn’t choose it install docker when I installed AMP. Is there any way to fix this?

If you run bash <(wget -qO- installDocker as root - it’ll install Docker and make the necessary changes for you.

Exactly the same problem.

I set up a fresh instance, enabled docker, then did the uupdate and then tried to start the server. It is stuck at preparing to start again, with nothing more in the log after the update.

Sorry, what am I supposed to do with that?

Just highlighting that the current template does not specify the correct docker image (for Xvfb), so it won’t work in docker atm, until that PR is merged

I’ve merged the changes in - if you tell AMP to fetch the latest configurations (Configuration → Instance Deployment → Fetch Latest) and make a new instance, it should all work now.

OK cheers will try it and let you know if it doesn’t work.

Now trying to figure out the correct child process to monitor so that metrics are correct - obvious choices like proton and wine64 don’t seem to work

I can’t get the server to start. It gets past the place it was stuck before, but now I have been looking at this for the last 10 minutes, and server has not started.

Yes, it seems to struggle in docker. I have a theory that the env vars that AMP sets don’t get passed into the docker container

So doesn’t work with docker, doesn’t work without docker. I have only tried setting up two servers since I purchased AMP a couple of days ago. Last Oasis, which took manual steps to fix bugs in AMP to get it working, and now Conan Exiles, which doesn’t work at all it seems. Wishing I had bitten the bullet and installed these servers manually as I usually do, and not purchased AMP.

Is Xvfb installed on the host? That is needed to run Conan on Linux

Will check and install it if it isn’t, then try again.