Changing backup location for docker instances isn't working

OS Name/Version: Ubuntu Server 22.04 LTS

Product Name/Version: AMP Release “Callisto” v2.5.0.4

Problem Description:

I want to store my instance backups on my NAS. However, before I even tried backing up to that, I tried following the instructions on this page exactly to change to a different local folder: How to change backup locations. I stopped the instance, made the changes specified in that link, and restarted the instance.

When I create a backup on the instance, though, it never shows up in /media/backups/{InstanceName}. It only exists in the Local Backup Storage for that instance.

Steps to reproduce

Actions taken to resolve so far:

I’ve checked to make sure that the amp user is the owner of the /media/backups folder, and all subfolders.

I’ve also tried deleting and recreating the instance. On a side note, even with the New Instance Defaults set to /media/backups/{InstanceName}, the new instance still starts out set to ./Backups/

I’ve looked at other posts with similar issues (though most seem to be non-docker instances) and tried the suggestions there, but most of the answers seem to just point back to the guide that I followed initially

The guide is wrong. You need to mount the path on the host into the docker container via custommountbinds in instances.json. @IceOfWraith needs to update the guide xD

Ah, okay. At least I’m not going crazy.

Thanks, I’ll look for that.

The guide should be updated now.

1 Like

Thanks! Got it working now.

Thanks boss! I’m too lazy to do it

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.