Ark Template not showing up

OS Name/Version: Ubuntu 22.04

Product Name/Version: AMP

Problem Description:

My problem is that there is no ark template showing up when I am creating a new instance. Have I missed something?

Steps to reproduce:

There aren’t really any steps just installed amp on a oracle cloud server.

Actions taken to resolve so far: None

Go into Configuration > Instance Deployment > Configuration Repositories and click “Fetch Latest”

Check the console to make sure the git pull is successful. If it is, refresh the page and it should now be in the list.

Now when I am trying to start it. It keeps saying its updating and installing stuff and then never starts.

See ARK: Survival Evolved Guide

Section 5 might be relevant to you.

I don’t think it is relevant I’ve also tried multiple other games and with all of them I have problems installing components. It’s just stuck on the installing components with other games but with ark it just says things are installing like steamcmd, etc… and then do nothing. When I try to start again it just does the same thing.

Sounds like you didn’t install the 32 bit deps for steam commands when installing amp.

You can run as root: bash <(wget -qO- installSrcdsDeps

I don’t think it did anything it still doesn’t work and I had to redo the whole installation and said aborting at the end.

Try a reboot after installing the deps

Rebooted it still does the same thing

It shows this message at the end of the install:

amp already has instances. AMP appears to be already installed and configured. Aborting…

Oh, lol, just saw you mention oracle cloud in the first post. That is ARM based, very few game servers will work on it, even fewer natively.

Steamcmd won’t work at all unless you use cross platform emulation to emulate an x64 system. You would have been prompted for this when installing AMP. Even then only a few servers are likely to run, and could break at any time with updates.

There is a KB in this discourse on ARM compatibility. Basically it’s “good luck”.

So do I need to reinstall AMP with cross platform emulation. And hope ARK wil work?

You can run the script again with upgradeCPX at the end (iirc that is the right function) and it will just run that part of the script

It gives an error:

No such function upgradeCPX

Rip. Will have to try to find what it is called now

configureDarkMagicNew is the function name

It still doesn’t work. Have tried multiple other games again but they all didn’t work. I think I’m just gonna reinstall it completely tomorrow and if it still doesn’t work I give up.

Very few games work on ARM systems. It’s a bit of a crap shoot.

I reinstalled with the cross platform emulation and now it works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.