AMP Instance Manager Unable to Connect to after update to newsest version

OS Name/Version: Windows Server 2016 Datacenter (10.0.14393)

Product Name/Version: AMP Instance Manager

Problem Description:

After updating my AMP Instance Manager I’m unable to reach / configure my local AMP instances always getting error: Unable to connect to

What I tried was the following:

Uninstall / Reinstall - not working
Uninstall / Reboot / Reinstall - Not working
Uninstall / Reboot / Reinstall / Reboot - Not working
Repair Installation - Not working
Repair Installation / (immediate) Reboot - not working

I’m really helpless what to do.
Hopefully someone is able to help me to “re-access” my local AMP Instances.

Thanks a lot for your help and greetings!


Hi, thanks for the detailed post - can you follow the steps in this post please? Something not working on Windows? Try the following:

Hi MIke!

First let me thank you for your help.
I was finally able to update the Instance Manager and I am able to access it again.
But,…here comes the but.

I am unable to start the services.
I get the following messages in all three instances log files.

Any Idea?

[14:45:26] [GSMyAdmin Info] : Running in a Xen environment.
[14:45:26] [GSMyAdmin Fatal] : AMPService cannot be run root/admin.

I use a dedicated user for the services which is in the local admin group.

Thanks for helping so much!


I believe this is the issue. For linux, AMP doesn’t like root/admin. I don’t know about windows though

Anybody else got an idea how to solve this issue? Iˋm unable to install and run AMP at the moment, Nothing is working. Thanks for helping and greetings!

Did you create a separate AMP user when you installed AMP?

Hi Mike,

yes I created a user.
There seems to be some strange behaviour with the users.
I created a new one and tried to run the service with that user.
Shall I reinstall with the different user?`I’m actually installing as my local admin user (not build in admin) and switch the user running the services afterwards.
Should this work?

Meanwhile I got some additional info:

So, I did the whole repair / reboot procedure with the latest versions of AMP using my AMP user. I was able to access the AMP Instance Manager again and I could update the services to the latest version. Once I try to start the services I get the following error: The AMP-ADS01 service terminated unexpectedly.
So, basically I’m still unable to start the service.
Do you have any idea how I can get a detailed error log for the services?
In the details view in Windows I see the following:

  • System

    • Provider

    [ Name] Service Control Manager
    [ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
    [ EventSourceName] Service Control Manager

    • EventID 7034

    [ Qualifiers] 49152

    Version 0

    Level 2

    Task 0

    Opcode 0

    Keywords 0x8080000000000000

    • TimeCreated

    [ SystemTime] 2022-05-30T08:14:27.654880600Z

    EventRecordID 833992


    • Execution

    [ ProcessID] 640
    [ ThreadID] 720

    Channel System

    Computer vmd32031


  • EventData

    param1 AMP-ADS01
    param2 2

Binary data:

In Words

0000: 004D0041 002D0050 00440041 00300053
0010: 00000031

In Bytes

0000: 41 00 4D 00 50 00 2D 00 A.M.P.-.
0008: 41 00 44 00 53 00 30 00 A.D.S.0.
0010: 31 00 00 00 1…

I don’t know what to do more… :frowning:



I meanwhile got everything up and running besides a minor issue I still face.
What I did:

  • remove the user I created for AMP from the Administrator group
  • created a new user group in Windows and gave that group all accesses needed to run AMP
  • added the AMP User to that group
  • repaired the installation from that users account
  • reactivated the licenses (they had all been gone)

So now I am running 2 of my 3 servers again.
One is still not able to start.
It says:

No valid AMP licence was found. Please run ampinstmgr reactivate XXXXXXXX to reactivate this instance.
If i do so everything seems to work as intended but the error stays.
I meanwhile send a mail to the support to get help with my CubeCode liecensing.
I can’t access my license manager and I don’t know if there is an issue with the active servers being licensed. (maybe to many activations)?

Do you have an idea about this?