Will not start!

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

Make sure you search before posting! Duplicate posts for the same issue may not be answered.

OS Name/Version:
Windows Server 2022 Datacenter
Version 21H2
Installed on ‎5/‎18/‎2023
OS build 20348.2582

Product Name/Version: (Always use the full version number - not ‘Latest’)
AMP Instance Manager v2.5.1 built 03/07/2024 19:18

Problem Description:
It said there was an update, I clicked on update. It did whatever it normally does to update and then I started the Service because it NEVER restarts the service.
Then it would not start.
Followed the " Something not working on Windows? Try the following:"
Even though there are no instructions on how to “run it in Repair mode”.
Restarted multiple times.
Tried doing the updateall.
Tried doing the upgradeall.
Restarted multiple times.
Looked at the “logs”

[13:24:22] [Webserver Info/15]    : RouterTimer@10Hz with 2 jobs started
[13:24:22] [GSMyAdmin Info/6]     : Webserver started on http://0.0.0.0:8080
[13:24:22] [GSMyAdmin Info/6]     : Checking for AMP updates...
[13:24:22] [System Info/6]        : Startup mode is UpdateAndStart.
[13:24:22] [GSMyAdmin Info/13]    : A new update is available!
[13:24:28] [InstanceManager Info/3] : Waiting for AMP instance to start...
[13:24:28] [InstanceManager Notice/3] : AMP instance Minecraft02 is now running.
[13:24:35] [InstanceManager Info/9] : Waiting for AMP instance to start...
[13:24:35] [InstanceManager Notice/9] : AMP instance PalworldModded01 is now running.
[13:24:42] [GSMyAdmin Warning/12] : Slow method invocation: Login took 2948ms to complete.
[13:24:42] [GSMyAdmin Warning/12] : Slow response: Core.Login took 2988ms to complete.
[13:25:07] [InstanceManager Activity/8] : Instance PalworldModded01 has stopped
[13:25:07] [ADS Info/8]           : ADS logged stopped instance PalworldModded01 - exit code 17 (MODULE_INIT_FAILED)
[13:25:18] [GSMyAdmin:admin Warning/21] : Slow method invocation: GetSettingsSpec took 2376ms to complete.
[13:25:18] [GSMyAdmin:admin Warning/21] : Slow response: Core.GetSettingsSpec took 2378ms to complete.
[13:25:37] [ADS:admin Activity/17] : Deleting instance 42700706-3556-455e-b2b4-2b95a6cd1118
[13:25:39] [GSMyAdmin:admin Warning/17] : Slow method invocation: DeleteInstance took 2395ms to complete.
[13:25:39] [GSMyAdmin:admin Warning/17] : Slow response: ADSModule.DeleteInstance took 2398ms to complete.
[13:25:52] [GSMyAdmin:admin Warning/19] : Slow method invocation: GetSupportedAppSummaries took 32348ms to complete.
[13:25:52] [GSMyAdmin:admin Warning/19] : Slow response: ADSModule.GetSupportedAppSummaries took 32350ms to complete.
[13:25:54] [GSMyAdmin:admin Info/17] : Stop requested: AMP update requested via API
[13:25:54] [GSMyAdmin Notice/6]   : AMP shutdown requested.
[13:25:54] [GSMyAdmin Notice/6]   : Stopping Application...
[13:25:59] [GSMyAdmin Notice/6]   : Stopping Web Server...
[13:25:59] [Webserver Info/15]    : RouterTimer@10Hz stopped
[13:25:59] [GSMyAdmin Info/6]     : Web server shutdown.
[13:25:59] [GSMyAdmin Notice/6]   : Goodbye!
I miss you Casper. <3

Not sure what else to do, now it isn’t working…