Wget: invalid option

OS Name/Version: Ubuntu 22.04 LTS

Product Name/Version: (Always use the full version number - not ‘Latest’) I have no clue where to find this information! The website just has a ‘download’ button which then tells you to run a batch script! So I’m going to have to just say ‘Latest!’

Problem Description:
I’ve tried to use the install script on a VM Ubuntu server running in proxmox. Its a new OS install with updates and has access to the internet.

When I type in the command I just get:

wget: invalid option -- '0'
wget: invalid option -- '_'
Usage: wget [OPTION]... [URL]...

I’ve searched for this issue in the forum but haven’t found an answer, so apologies for any repetition.

I wondered if the 0 was a zero or the letter o, but I’ve tried both. If u use the letter o nothing happens at all - just back to the prompt.

I am root and not using sudo before the script command.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1
    escalate to root
  • Step 2
    type in bash command as given on install page
  • Step 3

Actions taken to resolve so far: none - I haven’t a clue what to do!

You’re typing the command wrong. You should just copy and paste it.

There also is no _ in the command. So that’s another typo.

Seconding what Ice said - copy and paste the command, don’t type it. Use an SSH session.

It’s bash <(wget -qO- getamp.sh) Upper case letter ‘o’.