Wake Up not working on Valheim server

OS Name/Version: Microsoft Windows 11 Home

Product Name/Version: AMP Release “Halimede” v2.4.0.10, built 27/10/2022 18:15

Problem Description:

“Wake up” does not work, neither the button in the AMP management panel, or the action itself when trying to join the server to wake it up. It hasn’t worked even once since the start of my Valheim server. I get the message popup "Could not complete action. There is nothing on the console saying anything.

Steps to reproduce:

  • Let server go to sleep/force server to sleep
  • Press wake up/attempt to join server
  • “Could not complete action.” message pops up, console stays empty.

Actions taken to resolve so far:

I’ve tried disabling sleep and then enabling it, does not work. Edited sleep delay, doze delay, retry count and startup timeout. Nothing helped. I’ve had to disable Sleep Mode. I’ve "Stop"ed the server and then restarting it again to make the server go online, but I’m also having issues with the “Stop” since it starts an infinite “Stopping Valheim” so that’s a whole other issue… I have to stop the instance from the “Instances” tab actions to start or stop the server. (This is ok, my issue is the sleep problem since it’s annoying to manually stop and start the server each time it gets empty.)

How are you connecting? Via the steam browser or in-game?

I’m connecting from in-game, and so is my friend. Via the favourites.

  • Connecting via steam server list isn’t possible (added the server manually to the list) since the server shows as “< not responding >” on the list, and nothing happens if I try to connect via the list despite it saying not responding.
  • The Connect to Server button on AMP also doesn’t work. It gives Steam the wrong IP address to connect to. “Says Failed to connect” in game after imputing password and selecting character which to log in with. (I got the right IP to connect to from the console, then pasted it to ingame and joined that way the first time, after that via the Favourites.)

Connecting via faves or recent works, we get in the server fine, but doesn’t wake the server up if it’s asleep. (Neither does the AMP wake up button, so if it’s asleep the only option is to Shut down and then Start.)