Valheim Plus instance fresh install - Cannot start server

OS Name/Version: Canonical Ubuntu 20.04-aarch64-2022.04.19-0

Product Name/Version: AMP Release “Triton” v2.3.2.12, built 06/05/2022 17:18

Problem Description:
I’m just trying to start a fresh instance of Valheim Plus but i’m always getting the same error when i try to start the server:
"ERROR: object ‘’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored."

I tried another instance of Valheim (not plus) and it’s working fine.

Steps to reproduce:

  • Main menu of AMP → Create new instance
  • Select Valheim plus and hit Create Instance
  • Start the instance
  • Righ click on the new instance and Manage
  • Click on console → Start
  • The error appears and the server wont start

Actions taken to resolve so far:

  • Tried to download the last version of Valheim Plus from Github and replace the files from the instance witth the new files
  • Tried this solution as well but nothing

Valheim+ isn’t supported on Aarch64, only vanilla Valheim. Mods generally don’t work with the emulation layer. There is no fix for this issue.