Valheim instance: Invalid Username or password and wrong instance port showing

OS Name/Version: Ubuntu 20.04.1

Product Name/Version: AMP v

Problem Description: After setting up a new Valheim instance, I can’t interact with it in anyway. I just get “Failed to login to remote instance. Invalid Username or password.”.

AMP instance Valheim01 is now running.
Managed remote instance Valheim01 at
Authentication token for xxx requested by ManageInstance on behalf of xxx
Returned exception from API call ADSModule/Servers
[0] (SocketException) : Connection refused

Additionally, when I try to login to the instance from the Valheim client, it fails with “Failed to connect”. Another thing I noticed is the logs say the instance is on port 8082, but the “Instances” page says it’s on port :2456 and status is “Running” but CPU and Memory usage are all 0.

Seems ampinstmgr status says Valheim is on port 8082 as well:

amp@xxx:~$ ampinstmgr status
[Info] AMP Instance Manager v2.4.1.2 built 21/12/2022 17:55
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance Name      │ Friendly Name    │ Module     │ IP              │ Port  │ Up
ADS01              │ ADS              │ ADS        │         │ 8081  │ ✓
Valheim01          │ Valheim          │ Generic    │       │ 8082  │ ✓
Satisfactory01     │ Satisfactory     │ Generic    │       │ 8083  │ ✓

Steps to reproduce:

  • Setup new AMP instance on Ubuntu
  • Install Valheim instance all default settings
  • Go to Instances => Double click Valheim

Actions taken to resolve so far:

ampinstmgr --nocache upgradeall

Did sudo apt-get upgrade and update. Nothing’s worked.

I’ve also tried installing other games like Satisfactory, very similar results. Port shown in instances tab is wrong and I get invalid usenrame/password error when trying to manage the instance in any way.

Check your Default auth Server. It should be Set to on your Setup. After that, you need to create a new instance. You should be able to manage the new instance and inside the instance you can Update and Start the application

So is the Web UI. I can login to it fine. Only weird thing is it seems to kick me out after I double click on any game instance and get the password error. Also, FWIW, the first thing I did when I started my AMP server was to change my login password. Not sure if that messed things up somehow…

Sorry, I was Not clear enough :smiley: Writing from Phone at the Moment ^^
The Default auth Server is a setting in the new instance defaults. The Main Panel, an AMP instance of the Module ADS and normally named ADS01, is your auth Server. Every Game instance is a Copy of AMP running on Ports after 8080. Port 8080 is the Default for the First ADS instance, but can be different If the Port was already taken in install. Probably your Default auth Server setting points to Port 8080 which you need to change.

Sorry, If some words are Not correct :slight_smile: Auto correct on mobile makes it difficult for me :smiley:

1 Like

Ok, sorry, I misunderstood this instruction. The default auth server was set to port 8080 for some reason. This was after doing the default install… possibly because that port was in use aleady? Anyway, updating this seemed to have fixed things. The port shown on the instance page and the port shown via ampinstmgr status is still different though…

Haha, my instructions were Just Not clear enough :smiley:
The Ports 80xx are the Ports of the AMP instances. Iirc, the endpoint should contain the application Port. You can Always right click an instance and at Edit Ports (or whatever it’s called), you can See the assigned Port for that instance.

Remember to manage the instance and inside the instance to click on Update at the Status or console Tab. The running state you See in your Main Panel Page refers to the instance and Not to the application the instance is managing. You will See the correct state of the application inside the instance(manage) at the Status Tab. There is also a setting inside the instance named “Startup Mode” or similiar under “AMP Core”, iirc, to Set If the application should start with the AMP instance.

Feel free to ask more questions :slight_smile: There is also a Discord Server If you haven’t Seen it yet. There are more people active, so probably faster answers :wink:

Thank you. Yes, it appears the port shown in the instances tab is the “public” one that users can connect through. Verified it to be working. The one shown in ampinstmgr status is something else… perhaps it’s working via firewall configuration. Oh well, everything is up and running so I’m happy. Thanks.