Update Failure with Seven Days To Die - I cannot Update to Alpha 21 on 7DTD

System Information

Field Value
Operating System Windows - Windows 11 Pro on x86_64
Product AMP ‘Decadeus’ v2.4.5.2 (Mainline)
Virtualization None
Application Seven Days To Die
Module GenericModule
Running in Container No
Current State Failed

Problem Description


My game will not allow me to update to the newest beta even though i updated the SteamDB to experimental

Reproduction Steps

  • I added the steam DB to the settings
  • I tried updating it, asking on reddit and discord
  • I got an answer and followed the steps but my server wont update

What does the console tab show after hitting update?

^after i hit update

^^after i click start

the error is because i have the newest config logs for the game
but i do not have the newest update, only the newest updates configs

Configuration → SteamCMD And Updates → Config File Version → 21.0 and higher.

was already activated

that was the only thing that went through

Configuration → SteamCMD And Updates→ Update check method / Release stream

is what failed, im still on the old alpha

Did you pick the beta before updating for the first time?

Yes I did, I’ve even uninstalled the instance multiple times and reinstalled with the settings enabled from the beginning

when you helped me reset my AMP instance to a working state i made sure to put in the config first because ive had this issue since last night

@IceOfWraith any idea here?

if i look at the log these are the only errors, idk if this helps but thats all i got

That’s AMP spam

No spaces in the beta setting?

if you mean
Configuration → SteamCMD And Updates→ Release stream

then no, im using an underscore

I meant at the end. Shouldn’t make a diff, but this is a head scratcher otherwise

the end has no space, i checked that too lol

UMOD isn’t released for a21 yet. Try making a new instance and don’t enable that setting.

Hey, looks like the config file layout in A21 has changed and options that previously existed in A20.4 are no longer the same.

2023-06-24T22:24:50 0.449 ERR Error parsing configfile property ‘ControlPanelEnabled’: Unknown config option

Follow these steps:

  1. Go to Configuration->Instance Deployment and Fetch the latest. (On controller and targets if using that setup)
  2. Only for existing instances - Right click the instance and Refresh Configuration.
  3. Inside the instance go to Configuration->SteamCMD and Updates and set the release stream to latest_experimental and choose the 21.0 config option in the drop down.
  4. Update the game server inside the instance using the Update button.

Awesome that worked. not sure why it did not automatically pull it when I updated amp and made a new instance (was only a hour or so before my original post)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.