Update Failure with Minecraft - minecraft server is not updating

System Information

Field Value
Operating System Linux - Debian GNU/Linux 11 on x86_64
Product AMP ‘Decadeus’ v2.4.6.4 (Mainline)
Virtualization QEMU_KVM
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Ready

Problem Description


i update the server here, and try to log in in the game, and it says that the server are still in 1.20.1, and my game is 1.20.2

Reproduction Steps

  • i trying stopping the server and updating
  • i tried 3 times

in your Minecraft Instance go to Configuration > Server Settings and then look at Official Version and see and make sure that is set to 1.20.2

Probably need to stop the instance from the main AMP page, then start it again.
That’ll update the version manifest

yes, it is in 1.20.2 (release), but is not working, tried to stop the instance and start again, and still the same error.

Did you hit “Download/Update” after changing the server version?

i actually have same issue and did everyting from this post

I seem to have the same problem. Trying to update from 1.20.1 to 1.20.2.
Pressing Update gives the message:

This task could not be completed: Performing Upgrade - For instance Minecraft Java - State: 3.
Minecraft Java

Edit - actually, I’m on Windows, not Linux like OP

Above works on all os but also make sure you have your amp updated as well

I’m using Amp 2.4.4, which I believe is up to date.
Official Version set to 1.20.2 in the instance settings.

“State 3” is not very helpful - what does that error message actually mean?

Also, I seem to be on 1.20, not 1.20.1, if that makes a difference.

You’ll want to update amp first, 2.4.4 is quite a few months behind.

To move to 2.4.5 and beyond you’ll need to rerun the amp installer as an upgrade on Windows, as the release system changed so new versions won’t be detected in 2.4.4.

1 Like

Thanks so much. That worked. Not sure how I would have found out AMP was out of date otherwise!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.