Update Failure with Minecraft - "host is using an older version"

System Information

Field Value
Operating System Linux - Ubuntu 20.04.6 on x86_64
Product AMP ‘Decadeus’ v2.4.6.4 (Mainline)
Virtualization QEMU_KVM
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Ready

Problem Description


“The host is using an older version of Minecraft”

I’ve tried updating AMP server and I’ve clicked the update button on the instance but still no luck.

Reproduction Steps

  • Set up AMP
  • Install a Minecraft instance
  • It worked well for months but now clients get a message saying, “The host is using an older version of Minecraft”

You’ll need to restart the minecraft instance for it to pull the most recent version list, then you should be able to update Minecraft from inside the instance.

OK, I hit the ‘Stop Instance’ button, then I started it again and hit the 'Update ’ button. I still get the same message from the client.

Under Configuration > Server Settings inside the instance, make sure your Server Type and Release Stream are correct for what you want.

Thanks, my ServerType is Bedrock (official pocket/win10 server) which is what I want as my son and his friends play on iPads.

The release stream is stable.

I’ve tried the ‘download/update’ button on that screen too, still no change.

The log says this:

Unable to get Bedrock version data from https://minecraft.net/en-us/download/server/bedrock

Seems I also have the same issue, been working fine until the client had a recent update and running the update looks like its working but doesn’t successfully download anything and apply it.

also running on ubuntu

Check the instance logs to see if you’re getting the same error.
Microsoft’s download servers love to time out for no reason, so you may need to wait till they’re playing nice again. (all this would be avoided if they’d allow clients to choose a specific version)

Seems the fix was to run apt upgrade, rebooting the server made no odds to the issue but following updating of ubuntu all is working again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.