Update Failure with Enshrouded - Update stops at "Install Windows Components"

System Information

Field Value
Operating System Linux - Ubuntu 22.04.3 on x86_64
Product AMP ‘Decadeus’ v2.4.8.0 (Mainline)
Virtualization OpenVZ
Application Enshrouded
Module GenericModule
Running in Container No
Current State Installing

Problem Description


The application stops at Update Step 5/5 - Install Windows Components
There is a progress bar that says “Running Update Executable” that is running forever.
When the server is stopped and started again, the Update button appears again. After pressing the update button the same as described above happens.

Reproduction Steps

  • Create Server for Enshrouded
  • Install wine manually via command line
  • Press Update in the Server Management Form
1 Like

I am also experiencing the same issue here - please let me know if you find a solution to this issue

Things I have done to attempt to fix the issue:
Create a new VM with AMP

  • install wine 9.0 (Since Greelan post stated having Wine 8.0+)
  • validate Wine working via notepad++
  • Install cabextract
  • Restart the VM of Ubuntu
  • Boot back up create a new Enshrouded Instance
    = Sits on: Update Step 5/5 - Install Windows Component

I am having exact same issue. Logs show the following message.

wine: Unhandled illegal instruction at address 00000001406728B4 (thread 0308), starting debugger…

It is limited so far that I can tell to Enshrouded. I have created a BeamMP and Sons of the Forest instance and able to start them and the game with no issues.

I am on Debian instead of Ubuntu though. Have checked for and installed all updates on OS and AMP.

I’m having the same issue, my environment
Ubuntu 22.04.3 LTS
AMP 2.4.8 - 20240125.2
Virtualization QEMU_KVM

Looking into https://github.com/CubeCoders/AMPTemplates/blob/main/enshroudedwinescript.sh I see only one package is being installed - vcrun2022.

When I tried to install it manually with “winetricks corefonts vcrun2022” both as root or amp user I got an error message

Executing wine vc_redist.x86.exe
02c8:fixme:heap:RtlSetHeapInformation HEAP_INFORMATION_CLASS 1 not implemented!
02d0:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
02d0:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."
02d0:err:systray:initialize_systray Could not create tray window
02c8:fixme:advapi:DecryptFileW (L"C:\\windows\\Temp\\{3026F042-B839-4608-BDFF-689BAECBD999}\\", 00000000): stub
02e8:fixme:heap:RtlSetHeapInformation HEAP_INFORMATION_CLASS 1 not implemented!
02e8:fixme:advapi:DecryptFileW (L"C:\\windows\\Temp\\{76C20D3E-3BAA-4DBB-AA20-D9F4A2EC48AD}\\", 00000000): stub
02f0:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
02f0:err:winediag:nodrv_CreateWindow L"Make sure that your X server is running and that $DISPLAY is set correctly."
02e8:fixme:ver:GetCurrentPackageId (0057FEB4 00000000): stub
02c8:fixme:ver:GetCurrentPackageId (0057FEB4 00000000): stub
warning: Note: command wine vc_redist.x86.exe returned status 183. Aborting.

That might be the source of the problem. Don’t know how to fix that though.

PS: I installed new VM with Centos 9, got the same behaviour, so it’s not an OS specific.

1 Like

Deleted instance and switched to containers for instance creation. Everything is working now.


Confirming, it’s working now, although Game Port (15777) show red sign. It is possible to find server and connect after adding server to the favorites in Steam as “Server IP”:“Query Port”.

Server is working now, although I had an issue with deleting the instance. The Enshrouded instance was still shown in the instance overview after I deleted it. What I did in my case:

  • Fixed AMP permissions first:
ampinstmgr fixperms
  • After that I was able to remove the instance from the overview
  • Created new instance (in my case I did not use docker)
  • Updated the instance
  • Started the instance

As @Conkeen stated, the Game Port shows a red sign, but that does not seem to be a problem.

I was able to connect to the game and play.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.