Update error, Failed to initialize Steamworks SDK for gameserver. No SteamClient02

Good day everybody

After an update a few days ago, the Counter Strike 2 server no longer starts with the following error:
“Failed to initialize Steamworks SDK for gameserver. No SteamClient02”
I’ve already tried a lot, so I wanted to ask if this error is already known. This is also discussed in some forums, but unfortunately without a solution

Thank you and have a nice Sunday

I have the same problem which I already reported on discord.

Yes, it’s quite tedious, I’ve already invested several hours and tried pretty much everything, but there’s no solution yet. All other instances start without any problems. Just not CounterStrike. Could you please report here if you know anything new?

it’s the same for me and I tested on two dedicated servers the same problem for both servers I created a request on discord.

I hope a solution will be found quickly.

This seems to have appeared with a recent update to CS2. I’ve tried a couple of changes but the problem persisted. Cause is unknown. Could be that CS2 now has an issue with being run as the network service user, which is what amp runs instances as

Can we get around the problem?

Unfortunately I don’t have a new solution yet, but I have 2 new error messages…

src\clientdll\steamengine.cpp (2647) : Assertion Failed: CSteamEngine::BMainLoop appears to have stalled > 15 seconds without event signalled

ERROR! Failed to start downloading item 0.quit