Unable to run Minecraft FTB with Modpack

OS Name/Version: Linux / Debian 11
Product Name/Version: AMP Release “Decadeus” v2.4.4
Problem Description:

I’ve tried to install FTB (new) with FTB Skies modpack.
However no matter what I try to do this it always fails.
Sometimes the installation seems stuck (The FTB installs and modpack too), but the panel reports:
Application State: Installing components

Sometimes if I try to reinstall, it shows following message during startup:

The update manager reported a successful update, but ./Minecraft/minecraft_server.jar is missing.

Actions taken to resolve so far:

  • I’ve checked installed java version. Now running java 17 TEMURIN, which is supported, because server is running outside the panel (however it is using bundled java package, and start.sh script)
  • Checked if server is using Server JAR [Autoselect] - And it is.
  • Tried to fresh install the minecraft instance. The Vanilla is running OK.

Now I am wondering if it would be good to create brand new template for my instance, however it misses the point of having dedicated Minecraft server template.

What else can I check?

Verify the mod did download and created the config and mods folder and put the correct files in there. Then go back to the Server Settings tab and change the server type to Forge. Then select the correct forge version that matches the pack. Leave the Server JAR as autoselect then click the Download/Update button. This will download and install forge. After that the pack should start to run once you start the server.

Thank you very much. This seems to resolve the issue.

The files were downloaded properly, but I did not know that the server type needs to be changed to Forge in order to run server.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.