Unable to reconfigure Or Update any instances

OS Name/Version: Windows 11 Pro

Product Name/Version: AMP Release “Decadeus” v2.4.6, built 09/08/2023 17:53
Problem Description:

Trying to edit instance settings in ADS (for example changing Start on boot to off and saving changes) gives a popup saying “Unable to reconfigure instance”.

When I update Containers and try to restart them, they wont start again. Also I am unable to change any container settings once they are made
Error log for tring to update container:

Returned exception from API call ADSModule/UpdateInstanceInfo
[0] (MissingFieldException) : UpdateInstanceInfo method requires ContainerImage(String) argument.
at GSMyAdmin.WebServer.WebAttributes.<InvokeMethod>() at GSMyAdmin.WebServer.APIService.<InvokeAPI>()

Error Log for trying to Update container and starting Up again

Waiting for AMP instance to start...
AMP instance Test01 is now running.
Managed remote instance Test01 at
Authentication token for Admin requested by ManageInstance on behalf of Admin
Instance Test01 has stopped
ADS logged stopped instance Test01 - exit code -1 (CATASTROPHIC_FAILURE)

Steps to reproduce:

Changing Container error

  1. Click on the 3 dots
  2. Click on edit settings
  3. change any settings
  4. Click Save changes
  5. get “unable to reconfigure instance error”

Cant update Container error:

  1. Click on the 3 dots
  2. Click on Update
  3. Press Shutdown and Upgrade
  4. Try to start and manage container
  5. Get “The specified instance is not running” error

Actions taken to resolve so far:

  • Reinstalled AMP with UAC enabled and all dependancies installed
  • Created new instances which have the same error
  • Restart PC

Im having the same issues. I upgraded to 2.4.6 Yesterday, now I can’t edit any instance settings, just says unable to edit instance with the error you posted.

Edit: Im also Running Linux Aarch64, on the latest release version. I have another setup on a secondary server still running the old version which works fine, however the main server does not.

Yeah im having the same problem and tried tech support ticket with no response. Kind of want my money back at this point

1 Like

It’s a known issue - the workaround is to temporarily turn the docker setting on, set the container image to cubecoders/ampbase then turn the docker setting off. Then you’ll be able to save.

como se realiza eso que mencionas ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.