Unable to manage instance

OS Name/Version: Server 2012 R2

Product Name/Version: Halimede v2.4.0.4

Problem Description:

I’m unable to control instance from director. I have a director and two nodes, linux and windows. All three are on the same version. I currently can’t manage the windows node at all.

When I double click the instance I want to manage (the only one on the node) there is a long wait before I get a “Instance Unavailable” message. The log is full of these messages;

[17:13:05] [System:Anonymous Error] : Failure to make API call to PrimeMaterial01 ( - retried 10 times : An error occurred while sending the request.
[17:13:05] [ADS:Anonymous Error]  : HttpRequestException
[17:13:05] [ADS:Anonymous Error]  : [0] (HttpRequestException) : An error occurred while sending the request.
[17:13:05] [ADS:Anonymous Error]  :    at ADSModule.WebMethods.<MakeInstanceRequest>()
   at ADSModule.WebMethods.<Servers>()
[17:13:05] [ADS:Anonymous Error]  : WebException
[17:13:05] [ADS:Anonymous Error]  : [1] (WebException) : Unable to connect to the remote server
[17:13:05] [ADS:Anonymous Error]  :    at Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
   at Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
[17:13:05] [ADS:Anonymous Error]  : SocketException
[17:13:05] [ADS:Anonymous Error]  : [2] (SocketException) : No connection could be made because the target machine actively refused it
[17:13:05] [ADS:Anonymous Error]  :    at Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
   at Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
   at Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

I’ve thought initially I was having firewall issues, so I removed that. The AMP port is listening. Default TLS and cipher suites. I deleted and reinstalled the instance, (carefully following the instructions for Windows) which actually worked initially, but after a few days and reboot we’re back here again.

Check the instances own logs. Right click on it → View logs.

I ran “ampinstmgr reactivateall” on the node and that allows me to access it once again. It was previously licensed, and I might know what happened? I added another volume to the server to use a target for backups. Was that it? It deactivated based on that?

There’s a bug in the current version of AMP that can cause new instances to immediately deactivate the second time they’re started. We’ve got a fix in the works for the next update.