Unable to install AMP - Linux Ubuntu 20.04

OS Name/Version: Ubuntu 20.04

Product Name/Version: AMP Instance Manager v2.3.3

Problem Description:
When trying to (re)install AMP, I stumbled across the following problem.

Normally, on my other instances, where I installed AMP for the first time, it went fine. I could also access the AMP in my browser via the correct IP address and port.

When (re)installing AMP on my instance, it went wrong. Down below the installation progress, with the error (marked in red).

Strange enough, the installation wizard doesn’t create a folder, named AMP, in /home/AMP. On other instances it did create the correct folder, but now it won’t generate.

Steps to reproduce:

  • Install AMP
  • (Delete AMP) - Optional
  • Reinstall AMP
  • (Installation problem)

Actions taken to resolve so far:

  • Removing AMP and reinstalling
  • Making folder in /home/amp
  • Setting up correct firewall ports (8081)
  • What else?

If you need any info, let me know.

Thanks in advance.

1 Like

Hi Paul_Verbael,

could you login with your amp user and type following lines in terminal?

cd ~
ls -al



Hey jkkopp,

Thanks for your response. When entering the suggested lines the terminal comes with a big list of files. I also see there are a lot of get-amp logs. Do you need these?

Let me know if you need further details.

Run ampinstmgr fixperms as root

Also show contents of ls -la /home/amp/.ampdata/instances/

1 Like

Hey Paul,

It looks like you didn’t set the permissions right.
Do you see a .ampdata folder?
You have to make this one accessable for your amp user.
I am not at home atm, so you could try it by yourself. Tell me if you solved your problem.

Regards, jkkopp

Hey Greelan,

Thanks for you response. When requesting the contents of /home/amp/.ampdata/instances, it says the requested folder doesn’t exist.

Looking via FTP, there isn’t even an amp folder in the home directory. Even after installing (and thus stumbling across the problem) it doesn’t appear.

I’ve tried earlier to run ampinstmgr fixperms, and trying to reinstall AMP, but that didn’t affect my problem, sadly.

ls -la /home as root?

Thought you said you manually created the home directory for amp

Correct, I’ve tried to manually create a folder. Only forgot to set correct permission for amp. Now I’ve tried to reinstall AMP, but it now comes with a different error, see down below.

The /home/amp folder is still empty, while it does have the correct permission to install.

Doing ls -la /home as a root comes up with the following:

root@Ubuntu-VPS:~# ls -la /home
total 16
drwxr-xr-x  4 root    root    4096 May 27 22:27 .
drwxr-xr-x 19 root    root    4096 May 27 22:20 ..
drwxr-xr-x  4 amp     root    4096 May 28 11:13 amp
drwxr-xr-x  3 mcadmin mcadmin 4096 May 25 15:07 mcadmin```

I suggest you delete the /home/amp directory entirely, then reboot and then try the script again

1 Like

Actually delete the amp user entirely too

Hey Greelan,

It’s fixed!

So what I did:

  1. Remove directory /home/amp
  2. Remove user amp
  3. Reboot system
  4. Reinstall AMP
  5. Follow installation wizard (No errors)

Thanks to both of you, Greelan and jkkopp!