Unable to find forge jar file for Minecraft server 1.18.2

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Windows 10 Pro

Product Name/Version: (Always use the full version number - not ‘Latest’) Direwolf20 1.18 1.8.0

Problem Description: I am able to download the Forge (40.1.67) successfully and the Direwolf20 1.18 1.8.0 pack. The only jar file available in the root of Minecraft appears to be the vanilla one (minecraft_server.1.18.2.jar). I’m unable to find the proper jar file to run for forge to load the mods.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1 - Create new instance of Minecraft desktop Java edition
  • Step 2 - Set server type to Forge.
  • Step 3 - Select specific version 40.1.67
  • Step 4 - Switch to Feed the Beast New Source
  • Step 5 - Select Direwolf20 1.18 1.8.0

Actions taken to resolve so far: Wiped the Minecraft folder multiple times and reinstalled. Tried the forge-1.18.2-40.1.67-installer.jar created by Forge install. Copied both the server and universal jar files from “C:\AMPDatastore\Instances\Direwolf20118\Minecraft\libraries\net\minecraftforge\forge\1.18.2-40.1.67” to the root of Minecraft. None of those options work. Using the vanilla minecraft_server.1.18.2.jar does load properly.

Modern forge servers don’t use a Jar file. You don’t need to download the file yourself either. Pick the forge version you want in AMP itself and hit update, it’ll download forge and it also tells AMP what version of Forge to start.

Do I pick the Feed the Beast pack first or last?

If it’s FTB you do that first, then tell AMP which forge version it is but don’t hit update.

1 Like

Success, thank you! That did the trick.

Unfortunately these steps have not worked for me. I use AMP to download/install the Direwolf20 modpack (MC v1.18.2 pack v1.9.1), then switch server type to forge and choose forge version 40.1.69 as that is what the client side reported as being used. Then when I launch the server, it says that forge is not found, downloads and installs, then when I launch the server, it does this again. It never gets out of this mode. AMP v2.3.4.4 build 26/07/2022 20:08.

Make sure the jar file option is set to “Autoselect” and that the forge release stream is “Specific Version”

That did the trick. Thank You.