Unable to connet with my AMP Valheim server on Oracle Cloud Arm Instance

OS Name/Version: [Canonical-Ubuntu-22.04-aarch64-2023.10.13-0]

Product Name/Version: AMP Release “Decadeus” v2.4.6.8, built 23/11/2023 12:47

Problem Description: I cannot connect with my Valheim server. It’s running on Oracle Cloud VM.Standard.A1.Flex Instance(4 OCPUs, 24 GB RAM). I followed instructions on Using AMP on Oracle Cloud here, and also added proper ingress rules on networks setting like this.

Steps to reproduce:

  • Step 1 made server
  • Step 2 updated and started
  • Step 3 tried to connect, but I can’t

Actions taken to resolve so far:
I have tried these commands as root user.

iptables -I INPUT -p udp --dport 2456 -j ACCEPT
iptables -I OUTPUT -p udp --dport 2456 -j ACCEPT
iptables -I INPUT -p udp --dport 2457 -j ACCEPT
iptables -I OUTPUT -p udp --dport 2457 -j ACCEPT
iptables -I INPUT -p tcp --dport 2223 -j ACCEPT
iptables -I OUTPUT -p tcp --dport 2223 -j ACCEPT
iptables -I INPUT -p tcp --dport 2224 -j ACCEPT
iptables -I OUTPUT -p tcp --dport 2224 -j ACCEPT
iptables -t nat -A PREROUTING -p udp --dport 2457 -j REDIRECT --to-port 2457
iptables -t nat -A PREROUTING -p udp --dport 2456 -j REDIRECT --to-port 2456
iptables -t nat -A PREROUTING -p tcp --dport 2223 -j REDIRECT --to-port 2223
iptables -t nat -A PREROUTING -p tcp --dport 2224 -j REDIRECT --to-port 2224

I don’t know if this made an effect, I could get in my server once. But after few seconds, I lost the connection.

Can you help me please?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.