Unable to connect to AMP with web browser

OS Name/Version: Debian 10

Product Name/Version: AMP v2.3.0.8

Problem Description:

Hello everyone,

I’m currently renting a VPS for a Minecraft server for a few months. The hosting company I rent it from sells a “ready to play” offer, where AMP is already installed. I haven’t had any problems so far.

Some time ago I updated AMP via my web browser control panel (IP address over port 8080): everything seemed to go well.

However, I restarted the VPS a few days later (which I’ve done in the past without any problems) and since then I can’t connect to the web browser control panel: I only get the following message, “This site can’t be reached / XXX.XX.XXX.XX refused to connect”.

I tried to restart the VPS again but nothing changes. I also checked the VPS firewall but everything seems normal.

I’m far from being a Debian expert and have little experience in server management via VPS: I don’t want to make a mistake by trying to solve my problem alone or by trying to find solutions on old similar topics on forums, which most likely applied to different situations than mine.

That’s why I’m creating this topic, in the hope that you can help me solve this problem, and at the same time that I can learn more.

Thanking you in advance.

Try running ampinstmgr -b

I just tried it after switching over to the amp user and this is what I get:

I get this no matter which ampinstmgr command I use.

You need to contact your host if AMP came preinstalled. Looks like you have an outdated instance manager.

Thank you for your answers: I just contacted the host about this.

I guess that, as AMP was pre-installed on the VPS from the beginning, I can’t take care of the problem myself as I don’t own the AMP license?

If it is a VPS and you have root control, you can do it.

You want to make sure the CubeCoders repository is installed and apt or yum should update the ampinstmgr core for you.



I got a feedback from the host and they have installed the latest version of AMP.
I can now connect to AMP via my web browser control panel (IP address over port 8080).
I was able to start my Minecraft server and I’m able to connect to it.

I was also able to update the Minecraft server to the latest version of the game (1.19) without any problems.
However I’m using Paper on the server, but now I’m unable to update Paper, I get the following error message:

Is there a problem with Paper and the latest version of AMP?

Not that I know of. Restart just that instance and wait a bit before telling it to update. Otherwise just supply the jar file yourself.

I restarted the instance, waited a while but the problem is still there.

I have reprogrammed the firewall of my VPS lately, can this impact the Paper updates?

For the “manual” update, I guess I just have to place the jar file in the Minecraft server files via the AMP files manager?