Unable to access instances after update from to

OS Name/Version: Ubuntu 20.04.4 LTS and Microsoft Windows 10 Enterprise LTSC

Product Name/Version:

Problem Description: Updated to the latest version, from I made sure to update my controller, my slaves, and my instances. After that, I got an error when trying to login to my instances, saying:

ADS is a newer version than this instance. ADS is version but this instance is version
Please update this instance.

Unsure if I had messed up, I tried repeatedly to ensure my instances were updated, however no matter what I did, I still couldn’t login

Steps to reproduce:

  • Step 1 Update master instances
  • Step 2 try to update instances
  • Step 3 see error

Actions taken to resolve so far:
Repeatedly trying to update from both the master instance, and the slave instances, to no avail.

You need to update the actual instances. You can do them in bulk on the command line by running ampinstmgr updateall as the user that runs AMP.

1 Like

ok… Quick question, does that work on windows?

Yes. AMPs commands are the same on both platforms for the most part.

1 Like

So even after running the command, and the console clearly showing that it pulled from the saved version, I am still running into the same issue. Any suggestions?

For example, this is what I get from the console (updating on a linux slave instance):
Screenshot 2022-09-10 202532
then this is what I get back from AMP:
Screenshot 2022-09-10 202706

Similar story when updating for the windows one.

try doing this:
ampinstmgr --nocache upgradeall

same issue, which confuses me… I dont understand why I would get the exact same error… Perhaps corrupted AMP install?

Try restarting AMP so it checks again. ampinstmgr restart ADS

Still didnt work, but intersting thing to note: it only says it skips the cache for the main ADS installation, not the instances under it, those all used the cached instance.

Under each instance there’s a file called AMPVersion - delete that file for each of them then restart them.

So the solution was actually super super simple, and I am sorry for wasting your time. I just had to run the console update on the master server, and I can access everything! Much thanks for the help though!!