"Two-factor setup failed" Error

OS Name/Version: Windows 10 Pro

Product Name/Version: AMP Instance Manager - v2.3.2.10

Problem Description: I cannot login into my admin account anymore. I forced 2FA for all users and when I tried to log back into my admin account to enable 2fa I keep getting “Two-factor setup failed”
despite using the right code. I am using Microsoft’s Authenticator app.

Steps to reproduce:

  • Step 1 - Enable force 2FA for all users
  • Step 2 - try to log into admin user
  • Step 3 - add qr code to Microsoft authenticator app
  • Step 4 - type in code to setup authenticator and attempt to move to next screen

Actions taken to resolve so far:
-Restarting the 2fa setup process
-Restarting computer/server
-Tried doing setup locally and remotely
-Tried Google authenticator app

You’re using an outdated version of AMP. Please update.

Is this my version?


I ran the ampinstmrg upgrade command and it said it upgraded successfully. But my version remains the same

EDIT: Uninstalled and reinstalled AMP. 2FA is completely broken and doesn’t work even after uninstalling and reinstalling. I went through the first time setup and still wasn’t able to use Authenticator app to setup 2FA still receiving the same error… At least I can access my account now. I will not being 2FA please fix it!!

For Windows you need to go and download a new copy of the instance manager itself. The update command only updates the instances.

You can disable the 2FA requirement by shutting down AMP, then editing your AMPConfig.conf for the ADS01 instance and changing TwoFactorMode to Optional.