Transfer Valheim World to AMP

OS Name/Version: Debian 11

Product Name/Version:

Problem Description:

I am trying to transfer my Valheim world save from a 4netplayers server to my own dedicated server setup on linode using the amp script. I can get everything working and the instance setup and connect to a world however when I transfer the .fwl and .db (whilst the instance is offline) and then restart the instance and reconnect, it just loads a brand new world and will not load mine. The file names are Dedicated.fwl and Dedicated.db and I’ve changed the settings in the server config to load a “Dedicated.db” file and this hasn’t worked. I’ve also changed the server name to the same name as original “THE KINGDOM” and nothing.

Any help would be appreciated.

Have you changed the world name setting in AMP to match? And did you use AMPs SFTP to load in the new world?

Hello, Mike.

I had been uploading the files into the worlds_local location using my root sftp. I have since uploaded them via the AMP SFTP details checked to ensure perms are set to 644 and when I restart the instance it just sets up a new world. Changes Dedicated.fwl to Dedicated.fwl.old and the same for the .db file.

I’m assuming the world name from is “Dedicated” and that is what I have set in the AMP server settings to no avail

Not really sure how else to proceed now.

I’m having the same issue. I upload the maps from my previous server then start the
server. It then makes a new world with my supplied info and renaming the maps I had uploaded. I’ve tried uploading via SFTP and via the file manage in the web interface, no luck with either.

I succesfully restored a world. I had to do it via ssh to the server.
When I tried to upload the .db via the sftp via amp web it just made a 0 kb file.
I uploaded the files via winscp and moved them to /home/amp/.ampdata/instances/your instance name/Valheim/896660/Data/worlds_local
I then gave them the correct owner and perms with chmod 0644 and chown amp:amp
I made sure the world name in amp was the same as the filename.

I had to start the server and stop for the files path to exist.

Hello there,

i did what you did and sadly it did not work, the console just spits out a lot of errors. im using a ovh dedicatedbox with ubuntu 22,04 so hardware at least should not be an issue

Did anyone ever have any luck with this?

I’ve noticed that the folder structure is a little bit different than above.
/home/amp/.ampdata/instances/Valheim01/Valheim/896660/Saves/worlds_local is where it overwrites the transferred world and replaces with a new one. Any time I put my world in there, it just overwrites it with a file with the same name.

Please help!