Time zone problems in triggering scheduled tasks. Incorrect timezone

OS Name/Version: win10

Product Name/Version: Halimede v2.4.0.10

Problem Description:

Timezone appears to be incorrect and have no way of changing. Task scheduled at 9:30pm everyday but is triggered at 8:30am everyday according to logs. Local time is UTC+11.

Time in logs and in web panel is displayed at correct local.

How can I resolve this issue?

Steps to reproduce:
Create any scheduled task.

Steps taken to resolve issue:
Restarts os system. I cannot find any settings related to time.

There is already an issue for this: Make Schedules user friendly again · Issue #720 · CubeCoders/AMP · GitHub