Testing some config additions to ARK generic app config json. Game.ini is blank

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP Release “Callisto” v2.5
Virtualization None
Application ARK: Survival Evolved
Module GenericModule
Running in Container No
Current State Ready

Problem Description:
I have made some changes to Ark-seconfig.json to add settings to the “/Script/ShooterGame.ShooterGameMode” section of Game.ini for ARK se.

I have changed the configmanifest.json locally to ensure I can see my changes in the UI, and they work as expected. I then went to check the game.ini to see my changes, and the game.ini is blank.

I have checked a backup of my game.ini from before I made the changes and can see that it was blank there too. Its not clear if the game.ini file has ever been populated.

I can see in the ark-semetaconfig.json in the templates repository that the game.ini section is missing ConfigFormat, and ConfigFormatRegex parameters. Is this required for the game.ini to populate correctly? If not, are there any other reasons why it isnt populating?


Steps to reproduce:

  • Create an Ark SE instance
  • Browse to /ShooterGame/Saved/Config/LinuxServer/
  • Check game.ini

Actions taken to resolve so far: Checked over configuration files and looked through amp templates. I dont know how to apply the metaconfig so I am unable to test any changes.

AMP doesn’t write settings into the ini if they are not there

Thank you.

Yea I think I’ve kinda worked it out. I manually copied over the game.ini defaults and they now update as expected.

Still not sure why the game.ini was blank though as I hadn’t touched it prior to this!

I’m guessing that means if any settings ever get added to a template, they need to be manually added into the config file before they work. It would be great to see some sort of feedback in the UI to say the setting doesn’t exist in config, or that it wasnt able to be changed.

Would be better if AMP wrote the settings in. That would solve SO many issues