Template creation : No targets could be found for the required platform with a provisioning score above 0

OS Name/Version: Centos stream 8

Product Name/Version: Network Edition

Problem Description:

I am using Network edition with subscription on a target / controller setup and have been trying to get templates to work. I keep coming up with the error :

No targets could be found for the required platform with a provisioning score above 0.

However both the target and the controller are set to 32 instances and creating instances work fine. I have tried on a standalone version with the same failure. I also tried setting up template roles and none template roles for this both do not change the outcome. I am sure I am missing a step but I do not know what it is.

Thank you in advance

Steps to reproduce:

 * Step 1 : created template on a controller to target setup. 

Actions taken to resolve so far:

* created multiple roles and users (both template and non-template) to no success

* double checked that I can create instances normally and make sure I was on the most recent release

* tried to create a template using a module then tried to create one using base application

> Blockquote

Right now, Network Edition requires that templates are created on each target and deployed from there. Creating templates at the controller level and deploying them globally is currently locked to Enterprise - but this is up for review for obvious reasons.

Ok that explains why I cannot deploy from controller! :slight_smile:

Now tested it and it seems I am getting the same message response when deploying templates at the target level from my recent attempt.

I created a new user and template role and template itself just now from the target directly. this must be something I am just doing wrong…

That might be a bug - it’s assigning it’s own provisioning score to 0 because it doesn’t think it has permission to use the feature. I’ll have to look into this.

1 Like