Stuck starting Risk of Rain 2 server

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version:
Ubuntu 20.04
Product Name/Version: (Always use the full version number - not ‘Latest’)
AMP version (Halimede), built 21/12/2022
Problem Description:
When I Start the server of Risk of Rain 2 (after the instance is created, it didn’t work in a container but without it works fine to create the instance) I get an error in the console:

/usr/bin/xvfb-run: 184: wine: not found

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1:
    I start the instance not in a container
  • Step 2
    I update it
  • Step 3
    Start it and it gives /usr/bin/xvfb-run: 184: wine: not found

Actions taken to resolve so far:
Reinstall it several times.

This is why it recommendeds you use a container :slight_smile: it has extra dependencies.

Thank you for the reply
When I tried to use it as a container the instance doesn’t start at all. it’s the only game that doesn’t start as a container, I tried Valheim, Corekeeper, Project Zomboid and they all start as a container, Risk of Rain 2 is the only one that got stuck but the logs doesn’t say much:

ADS logged stopped instance RiskofRain202 - exit code -1 (CATASTROPHIC_FAILURE)

To set up the containers I used this guide

Is this correct?

Check the logs for that instance after it fails to start.

Sorry for my ignorance on the subject but how can I check the logs for a instance that is unable to start?
If I enable the container on Risk of Rain 2 on the main AMP panel on the console it gives:
ADS logged stopped instance RiskofRain202 - exit code -1 (CATASTROPHIC_FAILURE)

If I disable the container for ROR2, the instance is able to run but in the instance log when I start the server it gives me:
/usr/bin/xvfb-run: 184: wine: not found
/usr/bin/xvfb-run: 184: wine: not found

So, if container is enabled on risk of rain 2, it doesn’t start the instance. if it is disabled, the instance starts but gives “wine: not found error” when I start the server.

What can this be? Did I install the Docker containers wrong? But other games works just fine while in docker containers, its only risk of rain 2

Right click the instance and hit View Logs :slight_smile:

Thank you, now I can see clearly why, but it is strange because I changed ports five times for any that is not used in the machine and I get same error.
I tried 19000, 35000, 15500 and I still get port issue. maybe it’s something else that I need to change port and not just the ones that are showed in “edit ports” option?

[18:47:13] [Core Info] : Starting AMP version (Halimede), built 21/12/2022 17:54
[18:47:13] [Core Info] : Stream: Mainline (Release) - built by CUBECODERS/buildbot on CCL-DEV
[18:47:13] [Core Info] : Running in a Docker environment.
[18:47:13] [Core Info] : OS: Linux / x86_64
[18:47:13] [Core Info] : CPU: Intel(R) Xeon(R) CPU X5670 @ 2.93GHz (6C/12T)
[18:47:13] [Core Info] : AMP Instance ID: 5d35e1a6-0d66-4ea2-a269-b62c555b7b1f
[18:47:14] [ModuleLoader Info] : Loaded GenericModule version by CubeCoders Limited
[18:47:14] [Core Info] : Metrics publishing is enabled at udp://localhost:12820.
[18:47:14] [ModuleLoader Info] : Loaded FileManagerPlugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : Loaded EmailSenderPlugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : Loaded WebRequestPlugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : Loaded LocalFileBackupPlugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : Loaded CommonCorePlugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : GenericModule requests dependency steamcmdplugin…
[18:47:14] [ModuleLoader Info] : Loaded steamcmdplugin version by CubeCoders Limited
[18:47:14] [ModuleLoader Info] : GenericModule requests dependency RCONPlugin…
[18:47:14] [ModuleLoader Info] : Loaded RCONPlugin version by CubeCoders Limited
[18:47:14] [Core Info] : Licence Present: AMP Professional Edition
[18:47:15] [FileManager Notice] : Using keypair with fingerprint fVkGeDeNow6k6+y74Jn9u3NvYF8TXyTa0lFolT0RQo4=
[18:47:15] [FileManager Info] : SFTP Server started on
[18:47:15] [WebServer Info] : Websockets are enabled.
[18:47:15] [WebServer Info] : Webserver started on
[18:47:15] [Logger Warning] : RouterTimer@10Hz with 2 jobs started
[18:47:15] [ErrorReporter Error] : Socket exception - Trivial error / user error. Will not be submitted.
[18:47:15] [Core Info] : Checking for AMP updates…
[18:47:15] [ErrorReporter Error] : [Error] — Begin Exception Data —
[Error] OS: Linux (x86_64/Docker)
[Error] Module: GenericModule, Version: AMP
[Error] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Error] Instance ID: 5d35e1a6-0d66-4ea2-a269-b62c555b7b1f
[Error] SocketException
[Error] [0] (SocketException) : Address already in use
[Error] at Net.Sockets.Socket.Bind (Net.EndPoint localEP)
at Net.Sockets.TcpListener.Start (Int32 backlog)
at m.Http.HttpBackend.ConnectionLoop ()
[Error] — End Exception Data —
[Warning] Last error was raised less than 60 minutes ago, error report will not be submitted.

[18:47:15] [ErrorReporter Info] : ####################################
[18:47:15] [ErrorReporter Info] : # Self Diagnostics #
[18:47:15] [ErrorReporter Info] : ####################################
[18:47:15] [ErrorReporter Info] : The IP and Port combination requested by the socket is already in use by another application. Either end the other application or re-bind this AMP instance to a different IP/port.

It’s the primary AMP port that’s in use. Run ‘ampinstmgr ports’ as the AMP user and see what’s going on.

Thank you for the reply

ADS01 is the name of the primary instance right? It gives me this:
[Info] Port usage for ADS01 (ADS)
[Info] Instance is currently running.
[Info] LISTENING 8080 TCP (Core.Webserver.Port)
[Info] LISTENING 2223 TCP (FileManagerPlugin.SFTP.SFTPPortNumber)
[Info] LISTENING 12820 UDP (ADSModule.Network.MetricsServerPort)

Still I don’t understand this happens only with Risk of Rain 2.

Any ideas?

I think Mike wanted you to check the ports of the game instance and not ADS01. But according to the log SFTP binds to port 19001 and AMP to 8081. Check If something else uses one of the ports already on your system.

1 Like

Correct those are the ports for ADS, not the ROR instance.

1 Like

Now I understand, thank you.
This are for the Risk of Rain instance.

[Info] Port usage for RiskofRain201 (RiskofRain2)
[Info] Instance is currently not running.
[Info] LISTENING 8081 TCP (Core.Webserver.Port)
[Info] CLOSED 19001 TCP (FileManagerPlugin.SFTP.SFTPPortNumber)
[Info] CLOSED 19002 Both (GenericModule.App.Ports.$ApplicationPort1)
[Info] CLOSED 19003 Both (GenericModule.App.Ports.$ApplicationPort2)
[Info] CLOSED 19004 Both (GenericModule.App.Ports.$ApplicationPort3)
[Warning] Some of the ports required by this instance are currently in use, which will prevent this instance from functioning correctly.

I changed 19002, 19003 and 19004 for another ports but I get the same error.

It’s the AMP port, 8081 that’s the problem. Either change AMPs port ranges to not include 8081 and re-make the instance, or find out what’s sitting on port 8081 and stop it.

Thank you so much for everything. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.