SteamCMD failing to update/download game (Terraria)

OS Name/Version: Ubuntu 22.04

Product Name/Version: “Halimede” v2.4.0.10

Problem Description: Error when attempting to update Terraria (Terraria non-legacy pre-made instance). Re-made instance fresh, and getting same error when downloading game.

Steps to reproduce:

  • Create instance using pre-made Terraria option
  • Attempt to download/update game
  • Observe failure

Actions taken to resolve so far:

  • Delete instance and create new instance
  • Rename libSDL2-2.0.so.0 to force it to redownload
  • Perform no-cache upgrade of instance
  • Change thread priority in Terraria server settings (only place with a thread priority option)
  • Search online for others with the issue who were able to resolve
  • Ensured sufficient disk space (63 of 491 GB in use)
  • Verified other SteamCMD games (Valheim pre-made) operate normally

Error when updating game on original instance as well as new instance:

Error when trying to “start” the game on the new instance is the same, minus the libSDL2-2.0.so.0 error.

We determined in Discord that this is a bad patch pushed by Valve for SteamCMD. Gotta wait for them to fix it.

1 Like

Got the same error when updating Satisfactory.
Could solve it by login in with anonymous and then updating the game worked fine.

1 Like

@Jannis_Goeing As someone new to SteamCMD, how might I be able to choose the anonymous login option? I was under the impression that if a game server required login to download, then a license for the game was required.

That won’t work in this case. I wasn’t aware Satisfactory didn’t need a login like that. Perhaps it can be adjusted to work without sign in. Terraria is downloading the regular game though. It won’t work without owning it, so you must sign in, unfortunately.

I feel like I should go ahead and mention a fix for this, here is the discussion on github. https://github.com/parkervcp/eggs/issues/1965 It seems SteamCMD is having an issue using multiple cores so we limited it to one. While only a band-aid and it definitely needs to be looked further into, it works.

Thanks for the input! That’s so messy. Valve needs to really get this resolved, sooner rather than later.