Startup Issue with Valheim - Valheim server won't start

System Information

Field Value
Operating System Windows - Windows Server 2019 on x86_64
Product AMP ‘Callisto’ v2.5.0.10 (Mainline)
Virtualization HyperV
Application Valheim
Module GenericModule
Running in Container No
Current State Stopped

Problem Description

Issue

the new instance just givea a CMD notification in the Console but doesn’t do anything else. The old server gives this error Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
Error! App ‘896660’ state is 0x606 after update job.

Reproduction Steps

  • updated AMP
  • tried to update and/or start valheim both don’t work
  • tried to install a new instance but this doens’t work.
1 Like

Having the same issue and tried the same steps.

0x606 implies a lack of disk space. Check the output of df -h

Im having the same issue and have tried similar steps to the original post with no success. It downloads the steam files but doesn’t do anything else.

Are you also on Windows Server or are you on Windows Desktop?

Since this one is more active then the other one, I will post my findings here.

Needed info:

Platform Windows 11 Pro
System Type x86_64
CPU Model AMD Ryzen 9 3900X 12-Core Processor
CPU Layout 1S/12C/24T
Installed RAM 32710
Virtualization None
Module ADSModule
Module Application Application Deployment
Loaded Plugins FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
Application Name AMPService
Application Version 2.5.0.10
Codename Callisto
Tools Version 2.4.8
Release Stream Mainline
Build Spec Release
Build Date 15/05/2024 22:35

Issue: Failing to download/update Valheim server files.

I have tried uninstalling and re-installing the valheim server.
Tried updating the instance itself.
Tried running said server inside and out of docker container.
Verified plenty of HD space.
All failed.

Workaround… I manually downloaded the valheim server files and copied them into AMP. At this point AMP was able to launch and fully load the server and was able to successfully connect to it. It was also able to properly download and install the ValheimPlus mod and BepInEx, but still unable to download/update the server files themselves.

Conclusion: Either a bad steamCMD.exe file, bad script (steamscript.dat maybe?) or improper method of passing commands to steamCMD.exe.

EDIT: I also tried to edit the steamscript.dat file using a different method of downloading the server files, but every time I tried to install/update the server this file was replaced regardless of having “keep steamCMD scripts” enabled both in AMP and also in the valheim server config section.

I hope this additional info helps resolve this issue.