Startup Issue with Source Dedicated Server - Unable to run

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.6.4 (Mainline)
Virtualization Docker
Application Source Dedicated Server
Module srcdsModule
Running in Container Yes
Current State Failed

Problem Description


It won’t even try to run, it just says “Unable to run”

Reproduction Steps

  • Create an instance for Black Mesa
  • Update Instance
  • Attempt to run server

For any users who are finding that Source based games such as CSGO won’t start on Debian 12 or newer versions of Ubuntu, find bin/ in your instances data under the srcds directory and rename it to - the server should then start as normal.

With Black Mesa specifically, you may want to try these steps as highlighted here: Black Mesa Server not starting after successful installation

I tried this and I can’t find bin/ for Black Mesa, and the other change that @austin suggested, I made and it didn’t do anything for me.

What about AMPs own logs, do they reveal anything useful?

Absolutely nothing, unfortunately.

Let me get back to you on this. I’ve not tried Black Mesa in a while. Suspect it may need an older Debian version.

It’s enough to change the game name to bms in apps.json inside the instance datastore. The instance needs to be restarted after doing so

I did this, restarted, nothing.

Before posting I made a new instance and it worked fine with that change. Both in and outside docker. Not sure what’s up in your case.

It might be a Debian issue?

Shouldn’t think so, given the AMP docker images are now Debian 12 based

When you try to start the server, what’s shown in the startup arguments under Support and Updates?

It still says the gamemode is BMG, but I set it as BMS in apps.json and restarted the instance, and even made a new one, still nothing.

I suspect you are changing app.json in the ADS datastore rather than the instance datastore

Anyway, the next AMP update will include a fix for this

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.