Startup Issue with Palworld - Won't startup

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.0 (Mainline)
Virtualization Docker
Application Palworld
Module GenericModule
Running in Container Yes
Current State Failed

Problem Description

Issue

This task could not be completed: Starting Palworld… - - State: 3.
Application failed to start 2 times consecutively.

Reproduction Steps

  • reboot the VPS server
  • Wont startup after updating Palworld
  • Looked at logs and shows nothing

15:18:07

tid(79) burning pthread_key_t == 0 so we never use it

Redirecting stderr to ‘/home/amp/Steam/logs/stderr.txt’

Logging directory: ‘/home/amp/Steam/logs’

minidumps folder is set to /tmp/dumps

[ 0%] Checking for available updates…

[----] Verifying installation…

15:18:09

UpdateUI: skip show logoSteam Console Client (c) Valve Corporation - version 1709846822

– type ‘quit’ to exit –

Loading Steam API…OK

force_install_dir “2394010”

15:18:12

Connecting anonymously to Steam Public…OK

15:18:14

Waiting for client config…OK

Waiting for user info…OK

@sSteamCmdForcePlatformType windows

@sSteamCmdForcePlatformType” = “windows”

app_update 2394010 validate

Update state (0x5) verifying install, progress: 0.01 (2004 / 39195172)

15:18:16

Update state (0x5) verifying install, progress: 4.23 (115095594 / 2717769030)

15:18:18

Update state (0x5) verifying install, progress: 11.23 (305100468 / 2717769030)

15:18:20

Update state (0x5) verifying install, progress: 19.20 (521939780 / 2717769030)

15:18:22

Update state (0x5) verifying install, progress: 27.51 (747663540 / 2717769030)

15:18:24

Update state (0x5) verifying install, progress: 33.61 (913338548 / 2717769030)

15:18:26

Update state (0x5) verifying install, progress: 41.98 (1140879540 / 2717769030)

15:18:28

Update state (0x5) verifying install, progress: 49.85 (1354789044 / 2717769030)

15:18:30

Update state (0x5) verifying install, progress: 58.03 (1577087156 / 2717769030)

15:18:32

Update state (0x5) verifying install, progress: 66.05 (1795190964 / 2717769030)

15:18:34

Update state (0x5) verifying install, progress: 74.00 (2011197620 / 2717769030)

15:18:36

Update state (0x5) verifying install, progress: 79.83 (2169532596 / 2717769030)

15:18:38

Update state (0x5) verifying install, progress: 87.51 (2378199217 / 2717769030)

15:18:40

Update state (0x5) verifying install, progress: 94.76 (2575331505 / 2717769030)

15:18:41

Success! App ‘2394010’ fully installed.

quit

15:18:42

tid(110) burning pthread_key_t == 0 so we never use it

Redirecting stderr to ‘/home/amp/Steam/logs/stderr.txt’

Logging directory: ‘/home/amp/Steam/logs’

minidumps folder is set to /tmp/dumps

[ 0%] Checking for available updates…

[----] Verifying installation…

15:18:43

UpdateUI: skip show logoSteam Console Client (c) Valve Corporation - version 1709846822

– type ‘quit’ to exit –

Loading Steam API…OK

force_install_dir “2394010/Pal/Binaries/Win64”

15:18:46

Connecting anonymously to Steam Public…OK

15:18:47

Waiting for client config…OK

Waiting for user info…OK

@sSteamCmdForcePlatformType windows

@sSteamCmdForcePlatformType” = “windows”

app_update 1007 validate

15:18:48

Update state (0x5) verifying install, progress: 11.86 (5242880 / 44194776)

Success! App ‘1007’ fully installed.

quit

15:18:49

15:20:58

tid(362) burning pthread_key_t == 0 so we never use it

Redirecting stderr to ‘/home/amp/Steam/logs/stderr.txt’

Logging directory: ‘/home/amp/Steam/logs’

minidumps folder is set to /tmp/dumps

[ 0%] Checking for available updates…

[----] Verifying installation…

UpdateUI: skip show logoSteam Console Client (c) Valve Corporation - version 1709846822

– type ‘quit’ to exit –

15:20:59

Loading Steam API…OK

force_install_dir “2394010”

15:21:01

Connecting anonymously to Steam Public…OK

15:21:03

Waiting for client config…OK

Waiting for user info…OK

@sSteamCmdForcePlatformType windows

@sSteamCmdForcePlatformType” = “windows”

app_update 2394010 validate

15:21:04

Update state (0x5) verifying install, progress: 10.71 (4196308 / 39195172)

15:21:06

Update state (0x5) verifying install, progress: 10.53 (286226100 / 2717769030)

15:21:08

Update state (0x5) verifying install, progress: 23.03 (626028724 / 2717769030)

15:21:10

Update state (0x5) verifying install, progress: 35.38 (961573044 / 2717769030)

15:21:12

Update state (0x5) verifying install, progress: 47.96 (1303408820 / 2717769030)

15:21:14

Update state (0x5) verifying install, progress: 60.54 (1645244596 / 2717769030)

15:21:16

Update state (0x5) verifying install, progress: 73.11 (1987080372 / 2717769030)

15:21:18

Update state (0x5) verifying install, progress: 85.38 (2320527540 / 2717769030)

15:21:20

Update state (0x5) verifying install, progress: 97.80 (2658054094 / 2717769030)

Success! App ‘2394010’ fully installed.

quit

15:21:21

tid(399) burning pthread_key_t == 0 so we never use it

Redirecting stderr to ‘/home/amp/Steam/logs/stderr.txt’

Logging directory: ‘/home/amp/Steam/logs’

minidumps folder is set to /tmp/dumps

[ 0%] Checking for available updates…

15:21:22

[----] Verifying installation…

UpdateUI: skip show logoSteam Console Client (c) Valve Corporation - version 1709846822

– type ‘quit’ to exit –

Loading Steam API…OK

force_install_dir “2394010/Pal/Binaries/Win64”

15:21:25

Connecting anonymously to Steam Public…OK

15:21:26

Waiting for client config…OK

Waiting for user info…OK

@sSteamCmdForcePlatformType windows

@sSteamCmdForcePlatformType” = “windows”

app_update 1007 validate

Update state (0x5) verifying install, progress: 7.12 (3145728 / 44194776)

15:21:27

Success! App ‘1007’ fully installed.

quit

Watching this because I’m having the same issue.

[20:33:47] [steamcmdplugin Info] : SteamCMD Update successful
[20:33:49] [Generic Info] : Extracting /AMP/palworld/2394010/Pal/Binaries/Win64/UE4SS_v3.0.1.zip to /AMP/palworld/2394010/Pal/Binaries/Win64…
[20:33:50] [Generic Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:33:51] [Generic Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:33:53] [Generic Warning] : The application stopped unexpectedly. Exit code 53
[20:33:56] [Generic Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:33:59] [Generic Warning] : The application stopped unexpectedly. Exit code 53
[20:33:59] [Generic Warning] : Application failed to start 2 times, not restarting.
[20:34:05] [Core Activity] : Authentication attempt for user admin from 127.0.0.1
[20:34:05] [Core Activity] : Authentication success
[20:34:11] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:11] [RCON Info] : Source RCON reconnecting…
[20:34:11] [RCON Info] : Source RCON disconnecting…
[20:34:17] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:17] [RCON Info] : Source RCON reconnecting…
[20:34:17] [RCON Info] : Source RCON disconnecting…
[20:34:23] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:23] [RCON Info] : Source RCON reconnecting…
[20:34:23] [RCON Info] : Source RCON disconnecting…
[20:34:29] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:29] [RCON Info] : Source RCON reconnecting…
[20:34:29] [RCON Info] : Source RCON disconnecting…
[20:34:35] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:35] [RCON Info] : Source RCON reconnecting…
[20:34:35] [RCON Info] : Source RCON disconnecting…
[20:34:41] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:41] [RCON Info] : Source RCON reconnecting…
[20:34:41] [RCON Info] : Source RCON disconnecting…
[20:34:47] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:47] [RCON Info] : Source RCON reconnecting…
[20:34:47] [RCON Info] : Source RCON disconnecting…
[20:34:53] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:53] [RCON Info] : Source RCON reconnecting…
[20:34:53] [RCON Info] : Source RCON disconnecting…
[20:34:59] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:34:59] [RCON Info] : Source RCON reconnecting…
[20:34:59] [RCON Info] : Source RCON disconnecting…
[20:35:05] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:05] [RCON Info] : Source RCON reconnecting…
[20:35:05] [RCON Info] : Source RCON disconnecting…
[20:35:11] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:11] [RCON Info] : Source RCON reconnecting…
[20:35:11] [RCON Info] : Source RCON disconnecting…
[20:35:17] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:17] [RCON Info] : Source RCON reconnecting…
[20:35:17] [RCON Info] : Source RCON disconnecting…
[20:35:23] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:23] [RCON Info] : Source RCON reconnecting…
[20:35:23] [RCON Info] : Source RCON disconnecting…
[20:35:29] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:29] [RCON Info] : Source RCON reconnecting…
[20:35:29] [RCON Info] : Source RCON disconnecting…
[20:35:35] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:35] [RCON Info] : Source RCON reconnecting…
[20:35:35] [RCON Info] : Source RCON disconnecting…
[20:35:40] [Core Activity] : Authentication attempt for user admin from 127.0.0.1
[20:35:40] [Core Activity] : Authentication success
[20:35:41] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:41] [RCON Info] : Source RCON reconnecting…
[20:35:41] [RCON Info] : Source RCON disconnecting…
[20:35:47] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:35:47] [RCON Info] : Source RCON reconnecting…
[20:35:47] [RCON Info] : Source RCON disconnecting…
[20:47:03] [API:admin Activity] : Starting the application.
[20:47:03] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:03] [Generic:admin Warning] : The application stopped unexpectedly. Exit code 53
[20:47:05] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:47:05] [RCON Info] : Source RCON reconnecting…
[20:47:05] [RCON Info] : Source RCON disconnecting…
[20:47:06] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:07] [Generic:admin Warning] : The application stopped unexpectedly. Exit code 53
[20:47:07] [Generic:admin Warning] : Application failed to start 2 times, not restarting.
[20:47:11] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:47:11] [RCON Info] : Source RCON reconnecting…
[20:47:11] [RCON Info] : Source RCON disconnecting…
[20:47:13] [API:admin Activity] : Starting the application.
[20:47:13] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:14] [Generic:admin Warning] : The application stopped unexpectedly. Exit code 53
[20:47:16] [API:admin Activity] : Starting the application.
[20:47:16] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:16] [Generic:admin Warning] : The application stopped unexpectedly. Exit code 53
[20:47:16] [Generic:admin Warning] : Application failed to start 2 times, not restarting.
[20:47:17] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:47:17] [RCON Info] : Source RCON reconnecting…
[20:47:17] [RCON Info] : Source RCON disconnecting…
[20:47:17] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:17] [Generic:admin Warning] : The application stopped unexpectedly. Exit code 53
[20:47:20] [Generic:admin Info] : Merging config file ./palworld/2394010/Pal/Saved/Config/WindowsServer/PalWorldSettings.ini (Template) using Unicode (UTF-8) encoding.
[20:47:23] [Generic Warning] : The application stopped unexpectedly. Exit code 53
[20:47:23] [Generic Warning] : Application failed to start 2 times, not restarting.
[20:47:23] [RCON:admin Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:47:23] [RCON:admin Info] : Source RCON reconnecting…
[20:47:23] [RCON:admin Info] : Source RCON disconnecting…
[20:47:29] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:47:29] [RCON Info] : Source RCON reconnecting…
[20:47:29] [RCON Info] : Source RCON disconnecting…

Adding more details. I’m running AMP Release “Callisto” v2.5, built 22/03/2024 17:32, fresh Palworld instance.

Logs show (at time of starting the server):
[20:04:59] [RCON Error] : Source RCON failed to connect: Connection refused. Reconnecting…
[20:04:59] [RCON Info] : Source RCON reconnecting…
[20:04:59] [RCON Info] : Source RCON disconnecting…

Firewall dump:
root@Minecraft:~# ampinstmgr dumpfirewall | grep Shenanigans
[Info] TCP/2226 (AMP:MondayNightShenanigans01:FileManagerPlugin.SFTP.SFTPPortNumber)
[Info] UDP/8766 (AMP:MondayNightShenanigans01:GenericModule.App.Ports.$GamePort)
[Info] UDP/27015 (AMP:MondayNightShenanigans01:GenericModule.App.Ports.$QueryPort)
[Info] TCP/25575 (AMP:MondayNightShenanigans01:GenericModule.App.Ports.$RCONPort)

What processor does your system have? And are you using Proxmox?

I don’t know what proxmox is and the server was working before then all of a sudden stopped working. I started a new instance and the new instance works fine. The processor in my laptop is intel CORE i7. Since i’m running it off of hostinger, I don’t see how my processor would matter since its running of their server, the instance worked before, and the second instance doesn’t have issues.

I’d like to know how to fix the instance that isn’t working incase this happens again. After spending $530, I’d hate to have a continuous issue and it not be workth it.

You should be talking to Hostinger in this case then. This forum isn’t part of them at all.

When I chose create a ticket through their web host, it brings me to this website to submit a ticket.

That’s because we supply the control panel software. But otherwise have no involvement with the servers.

Oh ok, so would this issue still be with ya’ll since it’s under the game panel? I just dont know how to handle this situation I’m having :frowning: I just know the instance won’t work anymore with the error code 53.

@Mike Yes I am using Proxmox. Is this an apparmour issue then? This is a Debian 10 virtual machine (QEMU).

root@Minecraft:~# lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
Address sizes:       40 bits physical, 48 bits virtual
CPU(s):              32
On-line CPU(s) list: 0-31
Thread(s) per core:  1
Core(s) per socket:  16
Socket(s):           2
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          15
Model:               6
Model name:          Common KVM processor
Stepping:            1
CPU MHz:             2399.996
BogoMIPS:            4799.99
Hypervisor vendor:   KVM
Virtualization type: full
L1d cache:           32K
L1i cache:           32K
L2 cache:            4096K
L3 cache:            16384K
NUMA node0 CPU(s):   0-31
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx lm constant_tsc nopl xtopology cpuid tsc_known_freq pni cx16 x2apic hypervisor lahf_lm cpuid_fault pti

Make sure the processor is set to ‘host’.

So how do I fix the issue I’m having?

You need to talk to Hostinger, I think the issue is how their system is setup and they’ll talk to us.

How do I get in contact with hostinger? I looked on their website but didn’t see anything about contacting them.

This is the reply I got so they’re leading me back to you guys. Seems to be a miss communication on how to deal with the issue…

The log you’ve provided indicates that you’re using AMP (Application Management Panel) by CubeCoders, which is a management tool for game servers and other applications. The error message “The application stopped unexpectedly. Exit code 53” suggests that the application you’re trying to run is encountering an issue that causes it to stop.

Here are a few steps you can take to troubleshoot the issue:

  1. Check Application Logs: Look for detailed error messages in the application logs that may indicate what is causing the application to stop.
  2. Verify Configuration: Ensure that the configuration files for the application are correct and do not contain any errors that could prevent the application from starting.
  3. Update and Validate: It appears that you’ve run SteamCMD to update and validate the application. Make sure that the application is fully updated and that all files are validated successfully.
  4. Check Dependencies: Ensure that all necessary dependencies for the application are installed and up to date.
  5. Resource Limits: Check if there are any resource limits being hit that could cause the application to stop. This includes checking CPU, memory, and disk usage.
  6. Docker Environment: Since the log mentions a Docker environment, ensure that the Docker container has the necessary resources allocated and that there are no issues with the Docker setup.
  7. RCON Connection: There are also errors related to RCON (Remote Console) failing to connect. If RCON is necessary for your application, ensure that it is configured correctly and that the server it’s trying to connect to is running.

If you’re unable to resolve the issue with these steps, you may need to contact CubeCoders support for assistance with AMP-specific issues or consult the documentation for the application you’re trying to run.

Since this issue is not directly related to Hostinger’s hosting services, I’m limited in how much further assistance I can provide. If you need help with your Hostinger hosting services or have other questions related to Hostinger, feel free to ask!

So I’ve narrowed down my issue to be Palworld modded. Can you try creating a Palworld vanilla server and see if you can get it to work?

I’ve been working with some Cubecoders folks in the Discord server. They suggest another thing to try is to delete the .wine folder within your instance. This is because the Wine prefix may not have been created correctly because they didn’t update the server first. Deleting the prefix then updating may fix that for you (it didn’t work for me though).

The .wine prefix folder is located at “/home/amp/.ampdata/instances/[your_instance_name]/palworld/.wine/”. This is the absolute path on the server. This may be different for you since you’re on a hosting platform.

Once you delete the .wine prefix folder, update the instance, then try to start it again.

I’m also going to experiment with setting up the server in Docker. Instructions for that are Configuring AMP to use Docker for instances - Knowledge Base / How To - CubeCoders Support, but you’ll have to work with Hostinger to get them to set it up. If they’ve already set it up, you’ll see the following option when you click the three-dot menu when viewing instances:

1 Like