Startup Issue with Minecraft - spigot.jar is missing

System Information

Field Value
Operating System Windows - Windows 11 Pro on x86_64
Product AMP ‘Decadeus’ v2.4.6.0 (Mainline)
Virtualization None
Application Minecraft
Module MinecraftModule
Running in Container No
Current State Failed

Problem Description


Anytime i try to switch, it tells me the jar file is missing for the specified minecraft mod, before it was forge and now its spigot. I tried refreshing the minecraft jar files and no new ones appeared.

Reproduction Steps

  • create server
  • set server to spigot
  • can not find spigot.jar

Did you hit Download/Update after you changed the server type?
If you did, do you have Git installed?

yes, both git is installed and i tried clicking update/download for the spigot version

Weird, what happens if you switch the server type to Paper? (It’s a more performant fork of Spigot with a different instillation process)

that worked, paperclip.jar instantly appeared in the jar list.

Good to hear! I’m not entirely sure what could be going wrong on the Spigot side of things given that you have Git installed. You should be better off with Paper anyway though, all the same plugins work and everything.

thanks, definitely new to all this. Have git installed for other reasons and it works, but i do have issues with AMP restarting, requires a reboot to run right again and what not. So it might be a perms issue on my side somewhere. Anytime i update as well, i get a long hangup. The update works but i still have to reboot my server pc to have it running again.

I’m not all that well versed with Windows, but I’d suggest shooting your logs over in the discord the next time something funky like that is goin on, someone with some Windows know-how might be able to narrow it down

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.