Startup Issue with Minecraft - Exception in thread "main" java.lang.IllegalArgumentException: kotlin.native.concurrent: Invalid package name: 'native'

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.6 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Failed

Problem Description


When I added the Sky Factory 4 modpack onto my server via curseforge, the server kept not starting and saying this: Exception in thread “main” java.lang.IllegalArgumentException: kotlin.native.concurrent: Invalid package name: ‘native’ is not a Java identifier

Reproduction Steps

  • Installed Sky Factory 4 on forge
  • Started the server
  • Server shuts down due to Exception in thread “main” java.lang.IllegalArgumentException: kotlin.native.concurrent: Invalid package name: ‘native’ is not a Java identifier

Are you running the server with Java 8?

Im running it with TEMURIN 8 (jdk)

Weird, what’s the full latest.log say? (use

Heres the logs, Vanilla Server Log [#Zm7GyM0] -

Looks like the server is running on Java 18 for some reason.
If the setting under Java and Memory says Java 8 still, try swapping it to Java 18, wait a second, then swap it back to Java 8.

I think that fixed that problem but now its saying this: Error: Could not find or load main class

Yeah, SkyFactory 4 needs Forge 1.12.2 to be selected. If you have Forge 1.20 selected it’s not going to load right.

Wow, that worked. You’ve been amazing, thank you so much. One last thing, I’m finally in the world but I’m trying to create/go to the island. I changed the generator-settings to {“Topography-Preset”:“Sky Factory 4”} and level-type to DEFAULT. Yet it still won’t let me create or go to an island with the /topography commands. Any ideas? Also how do I add prestige onto the multiplayer server, thanks.

I think there’s a way to do both of those on the server, but I can’t remember the specifics, the modpack zip should have a PDF with a bunch of docs.
With the generator-settings, you should be able to set them in the, then right click the file to import it into AMP. (be sure to delete the world folder between attempts)
If that doesn’t work you can start a singleplayer world with presteige enabled, save+exit, then upload the world folder to AMP over SFTP.

Alright so I tried what you said and it didn’t work, then I deleted the world folder and tried importing a new one but that just wasn’t working so I tried to just start the world again to get a new world folder but it wont even start. Here are the logs: Forge 1.12.2 Server Log [#GtbQVVY] -

Looks like it could be parsing the value funny, the " are being read as ???. What happens if you repeat things and leave the quotations out when importing the value?
If that doesn’t work then the tried and true “import-world-from-client” method should work. (the world-gen settings are baked into the world file, so it all carries over)

So I did as you said and I had to do the “import-world-form-client” to make it work. The sever starts again now at least but im still in a vanilla world. And anytime I try to do a topography command it says one of these things: Command can only be used if the overworld is created using Topography. An unknown error occurred while attempting to perform this command.

Maybe double check that the world file you uploaded has either been renamed to world, or change the setting under Server Settings to match the name of the world you uploaded.

Yep that fixed it, thanks for your help.

1 Like