Startup Issue with Minecraft - Can start the instance

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.8 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Failed

Problem Description

Issue

I have the following message

A JNI error has occurred, please check your installation and try again :

Exception in thread “main” java.lang.UnsupportedClassVersionError: net/minecraft/bundler/Main has been compiled by a more recent version of the Java Runtime (class file version 65.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Reproduction Steps

  • tried to restart it
  • cannot start it
  • please help

You need to use Java 21 with Minecraft 1.20.6

1 Like