Startup Issue with FiveM - Server not starting unknown reason

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.6.4 (Mainline)
Virtualization Docker
Application FiveM
Module FiveMModule
Running in Container Yes
Current State Stopping

Problem Description


I have updated the server and filled in the server settings page, and attempted to start the server, when I tried to start it the server refused to start with the issues of: server project and name were not in the cfg so I added them and it still did not work.

Reproduction Steps

  • Updated the server
  • Checked the console for issues
  • Updated the config with the console instructions.

Have you hit update so that the server downloads?

Yes, I have fully read through all the read me’s and followed all the instructions

Do you get any console output at all?


Console Listener setup OK

Started map fivem-map-skater

Started resource fivem-map-skater

server thread hitch warning: timer interval of 395 milliseconds


cccc ff xx xx rr rr eee

cc ffff xx rrr r ee e

cc ff xx … rr eeeee

ccccc ff xx xx … rr eeeee

Authenticated with Nucleus:


– [server notice: hostname_rework]

You don’t have sv_projectName/sv_projectDesc set.

These variables augment sv_hostname and fix your server name being cut off in the server list.

Use sets sv_projectName .. and sets sv_projectDesc .. to set them.

That is the console output,

I am able to start the server by running the in the amp five m folder but when amp tries to start it itself it does not work.

Sanity check - if you make a new FiveM instance, and make no configuration changes other than the bare minimum (the key), does it start?

#This file is controlled by AMP, any changes will be overwritten. If you need to add any extra settings, create a file called ‘user.cfg’ and AMP will append its contents after this line.

– user.cfg

sets sv_projectName “Matrix Gaming”

sets sv_projectDesc “Matrix Gaming”

#Lines below this point are controlled by AMP.

– server.cfg

sets PoweredBy “AMP by CubeCoders - CubeCoders

set udpLogAddress

sets tags “default”

sv_scriptHookAllowed 1

endpoint_add_tcp “”

endpoint_add_udp “”

rcon_password 1b7da2523b7d485aaa295cbebf666b94

ensure AMPFiveMIntegrationServer

stop webadmin

ensure mapmanager

ensure chat

ensure spawnmanager

ensure sessionmanager

ensure fivem

ensure hardcap

ensure rconlog

ensure scoreboard

sv_endpointprivacy True

sv_maxclients 32

sv_hostname “Matrix Gaming”

sv_licenseKey “cfxk_1CEecT7cV0jjC0yEzFnCN_2BYH68”

set steam_webApiKey “145C40D760508DD52E630C172213418A”

sets banner_connecting “”

sets banner_detail “”

load_server_icon “”

This is the AMP five M CFG and this does not include sets sv_projectName and sets sv_projectDesc but due to AMP managing the server.cfg i am unable to add these to the cfg as it rewrites it.

I have attempted to insert them into the user.cfg that still does not fix the problem either

And no it does not, even after configuring the TX Admin, so the server files are fully set up it still does not load.

I have created a full brand new instance done the update and then inserted the license key and it still does not load up.

How are you editing the user.cfg file? It looks like it should be OK.

As a quick check for permissions issues, you can run ampinstmgr fixperms as root.

Hey Alex,
Just to confirm you are modifying the user.cfg file and not the user.cfg section of server.cfg?

user.cfg should read like this:

sets sv_projectName "name"
sets sv_projectDesc "desc"

It is also worth noting that blacklist certain keywords (tags) from appearing in the name of servers. However I don’t think “Matrix Gaming” should trip that up.


I have tried all the solutions above and none have worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.