Startup Issue with BeamMP - BeamMP server not starting - hosting platform > Hostinger

System Information

Field Value
Operating System Linux - Debian GNU/Linux 11 on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization QEMU_KVM
Application BeamMP
Module GenericModule
Running in Container No
Current State Failed

Problem Description


Hello, i tried to start a BeamMP server but i can’t seem to make it start every time i try i get this error message: "This task could not be completed: Starting BeamMP… – State: 3.

Application stopped unexpectedly with exit code 127."
Can you please help me start it?

Reproduction Steps

  • Starting instance
  • Attempting to start server
  • Error in trying to start server

Did you select the Debian 11 server version for BeamMP - see Linux Server Version under BeamMP - Server Settings?

It was on Debian 12, now i changed it to 11 but it still doesn’t work

Did you update the server after changing?

Yes, but same error message

Have you included your Auth Key in the UI?

You might also need to install liblua5.3-0.

Just for giggles I created a server in a Deb 11 docker container, works fine with the Auth Key included and the lib installed:

[INFO] BeamMP Server v3.1.1
[INFO] Sentry started! Reporting errors automatically. This sends data to the developers in case of errors and crashes. You can learn more, turn this message off or opt-out of this in the ServerConfig.toml.
[INFO] Vehicle data network online on port 30814 with a Max of 8 Clients
[INFO] Vehicle event network online
[INFO] Server up-to-date!
[INFO] PluginMonitor started

How can i install liblua5.3-0 ?

Apt of course

apt install liblua5.3-0

You’re welcome

Sorry but how do i do that? I am parallel with this kind of stuff

Do you have SSH access to the server, so that you can access the command line?

If not, you will to contact Hostinger

Unfortunately I dont think I have

How did you install AMP in the first place?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.