Startup Issue with Assetto Corsa Competizione - need help with WINE problems for ACC

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization Docker
Application Assetto Corsa Competizione
Module GenericModule
Running in Container Yes
Current State Stopped

Problem Description


Hallo there AMP Support,
i bought the AMP pro license mainly for ark and for ACC (Assetto corsa Competizione) and i cant run the ACC server anyway. it says it is missing wine. but in the settings it also says on a linux container i dont have to install it. The big problem here is: i cant install wine, bc of missing linux install pathing and stuff. i need help to run the ACC server. especially i need help to run and install wine. the console err massage: ==ERR: This server is only supported on Windows operating systems. Running WINE may work dependent on your settings, but there are differences that affect the user’s experience negatively.

Reproduction Steps

  • settung up the acc instance as i have to do
  • i set up the options and diabled the mark that i have to disable for linux
  • i set up the server game config. to options that should run and already run on my old, pc hostet, server
  • and than i updated and startet the instance and the server. after a few seconds int says, it is a windows server thing, or i have to install wine.

Run this as root:

getamp installDocker

This will install the components needed to run the servers in containers, which spares you from having to install Wine etc on the host.

If you are running in docker, you are running with Wine. Check the Support and Updates tab and you will see the startup arguments.

The issue is, even with Wine, the ACC server is flaky. The warning it gives you confirms that.

When the template was created, it worked OK. Since then the server has changed, and it causes more issues. Not much that can be done - some (very few) servers just refuse to co-operate with Linux.

already did it is running as docker but already says the wine thing

Did you change the existing instance to be inside a container in its settings?

so i have to run the getamp installdocker command in amp itself? in the console tab? odere on my linux console before amp? and in the support tab there is no wine startup argument listed

You run it in a root shell, the way you did when you originally installed AMP.

but how do i fix it? i runn the amp system on a proxmox container with debian 12. when i use the command: getamp installDocker it says “already installed” so docker is installed

You already have it installed. You couldn’t have started the server and got that warning message without it, because that comes from ACC itself

ACC doesn’t know that it is being run in Wine. It just says that message regardless

so how can i run the server on amp in debian 12? i mean it has to work somehow or am i wrong?

From what it sounds like - it’s working fine. You can just ignore the warning it’s giving you.

so the error code is just a message from acc itself that it is running on wine? well maybe with rigged words and missunderstanding? alright that would explaint the wine error. but i can join on it. i port forwarded the ports that are listed in the amp instance and the Port that ACC dedicated server normaly uses by itself. its the 9600 and 9601

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.