Space Engineers - Error: No IP assigned

OS Name/Version: Ubuntu 22

Product Name/Version: - 20231005.1

Problem Description:

When starting the Space Engineers server, the log says that it has bound the IP Bind IP : And then gives a red error message saying Error: No IP assigned and the server start up fails shortly after. This keeps looping around never starting.

I have tried installing a fresh Space Engineers instance, accepting all the defaults, and exactly the same thing happens.


Please share the log.
I Just tried myself. I created and managed the instance, hit update, hit start and it works

Here you are:

2023-10-24 14:55:30.352: App Version: 01_203_024
2023-10-24 14:55:30.385: Is official: True [NO][NIS][NAMP]
2023-10-24 14:55:30.387: Client Build Number: 0
2023-10-24 14:55:30.387: Server Build Number: 0
2023-10-24 14:55:30.387: Environment.ProcessorCount: 8
2023-10-24 14:55:30.390: Environment.OSVersion: Microsoft Windows 7 Professional (Microsoft Windows NT 6.1.7601 Service Pack 1)
2023-10-24 14:55:30.390: Environment.CommandLine: “Z:\AMP\space-engineers-generic\298740\DedicatedServer64\SpaceEngineersDedicated.exe” -console -path /AMP/space-engineers-generic/298740/servers
2023-10-24 14:55:30.390: Environment.Is64BitProcess: True
2023-10-24 14:55:30.390: Environment.Is64BitOperatingSystem: True
2023-10-24 14:55:30.390: Environment.Version: .NET Framework 4.8.3761.0
2023-10-24 14:55:30.390: Environment.CurrentDirectory: Z:\AMP\space-engineers-generic\298740\DedicatedServer64
2023-10-24 14:55:30.390: CPU Info: Intel(R) Xeon(R) CPU E3-1275 v6 @ 3.80GHz
2023-10-24 14:55:32.531: Bind IP :
Setting breakpad minidump AppID = 244850
2023-10-24 14:55:45.856: Error: No IP assigned.

And then it just keeps looping around, trying to start over and over.

After a little experimentation, I have discovered that if I switch to EOS networking instead of Steam networking, the server will start.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.