Source Dedicated Server - "Connect to Server"-Button is local IP only

System Information

Field Value
Operating System Linux - Ubuntu 20.04.6 on x86_64
Product AMP ‘Decadeus’ v2.4.6.6 (Mainline)
Virtualization Docker
Application Source Dedicated Server
Module srcdsModule
Running in Container Yes
Current State Ready


I want to connect to the server via domain name

Problem Description



in my case, I am having an instance with Counter Strike Source. I created a user and gave permissions to manage the CS:S instance. Since not everyone with access to the instance will be in the same local network as my server is, I would like to make the “Connect to Server”-Button work from outside my home network via domain:


For SFTP this works, the link is not my local IP, it’s the domain that I have set up in the network settings.

I have also tried creating a new instance after setting up the base url in the network settings, just to make sure.

This was being asked before: Possible to show Domain instead of IP ?

If it’s still not possible at this time, can I remove the “Connect to Server”-Button? I don’t want my friends to get confused when trying to use it and get an error in the game :wink:


Reproduction Steps

  • Set up a Base URL in network settings
  • Create instance
  • Click on “Connect to Server” → but it’s local IP

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.